Showing no CDN

H there, I’ve set up Cloudflare but it’s still showing in gtmetrix that I have no CDN amongst other things please can you help?
The link is here https://gtmetrix.com/reports/rocheesblogary.com/gCnw4aSA

Cloudflare won’t show up as a “CDN” in GTMetrix given how it works, but if it’s correctly activated it works just fine for your own domain.

Ok thanks, I’m new to this and have only recently launched my site so still learning. Do you know how to change any of these errors please - enable keep alive, use CDN, add expires headers and reduce DNS lookups, please? Will appreciate any help. Thank you

  • Enable Keep-Alive: This is an issue with the Amazon ads you use, not your own domain. You would need to take that up with Amazon or remove the ads.
  • Enable compression: Also an issue with Amazon.
  • Leverage browser caching: This is an issue with Google Ads, YouTube, and some other Google services on your site.
  • Minimize redirects: This is, once again, partially an issue with Amazon.
  • Reduce DNS lookups: You have way too many ad networks.
  • Use a Content Delivery Network (CDN): Amazon ads.
  • Add Expires header: Amazon ads, Google Fonts

Dynamic ads and tracking tend to slow down sites. You can either remove the ads, implement static ads, or live with poor results on GTmetrix. You’re not going to max out your GTmetrix results if you have intrusive ads–that’s just the way it is. There’s nothing Cloudflare can do to fix that.

This topic was automatically closed after 30 days. New replies are no longer allowed.