Showing Apache2 ubuntu default page

I have added my site to cloud flare today and it is not working properly, it is showing Apache2 ubuntu default page. (https://iastopper.com/) https://prnt.sc/vvznm8
Please someone help me in this.
Thanks

Was your site running with HTTPS before you added it to Cloudflare?

No, it is on http.

That’s why. You need an SSL cert on your server. You can use one of these:

2 Likes

Thanks for your reply.
But I have already enables the ssl,
now when i switch flexible to full, the problem get solved.
Thank you very much,

1 Like

Great! Give Full (Strict) mode a try. That’s more secure than just Full because it checks for a valid certificate.

2 Likes

No it wasn’t work with strict one.
@sdayman One more issue I’m facing from yesterday is that my another site i.e. enlightias.com 's login button is not working sometimes. Can you plz help me in this?

I think you got Error 526 with Full (strict) mode. Try to install a valid cert in your server if possible. You can get one for free - from the Cloudflare Dashboard - SSL/TLS tab - Origin Certificates. If you stick with Flexible mode, your connection is not fully secure anyway.

You need to open F12 Developer Tools - Console tab and see what’s the error message when you click the Login button.

@erictung Thanks for your reply… here are the errors https://prnt.sc/vw8eu1 , now how can i solve them?

I noticed that you enabled Rocket Loader, and this could be the culprit (but I’m not sure). You can try disable it. It’s under Speed tab - Configuration.

You mean Rocket Loader plugin?? No, it is the preloader of theme.
and i also don’t use any cache plugin.

Nope. It’s in Cloudflare dashboard:

Done…but still same…
One thing i hv noticed is that this error is only on mobile phones not on desktop.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.