Should I enable Auto Minify and Image Optimization If I already have a plugin for it?

Hi, I’m making a WordPress site and I already have a Plugin that does HTML, CSS, JS optimization & minifcation, as well as Image compression & Webp should I also enable this settings on my Cloudflare dashboard?

I’d suggest you to remove the plugin from WordPress and leverage the web hosting/origin host/server work and resources including the CPU load to Cloudflare by enabling those features at Cloudflare dashboard :wink:

There is no need to do the same duplicated job.

Which Cloudflare plan are you using? Pro plan offers Webp and much more to try out :slight_smile:

1 Like

Yeah I have the pro Plan and I can use Webp,
I’m not sure why but there are some settings in the speed section that when I enable cause my site a lot of problem and I can’t access my admin area.
Its either Minify, img compression, img webp, or brotli compression. and I cant put my hand on which one is the case.
also I’m not even sure I should use the minify/webp/ img compression because my wordpress plugins already do that. Obviously if Cloudflare does it better than I’d rather Cloudflare do it which is why I’m asking

Hm, strange a bit. If so, might be a conflict with some script with the “Rocket Loader” feature and/or “Auto Minify” for JavaScript? :thinking:

Are you using some kind of a website builder plugin for your WordPress?

Try disabling Rocket Loader.

Then, use “Purge Everything” at CF dashboard → Caching → Configuration.
Wait for a minute.
Clear your Web browser cache or try using a different web browser to see if it still persists.

Furthermore, before moving to Cloudflare, was your Website working over HTTPS connection? :thinking:

Kindly, before doing anything at Cloudfalre settings, you could determine if you have a valid SSL certificate installed at the origin host/server by your web hosting provider or your own VPS/dedicated server following the steps from below:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Check with your hosting provider / cPanel AutoSSL / / Certbot / Let’s Encrypt or some other and renew it accordingly.
  5. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Hi, thank you for your response!
Yeah I have a valid SSL on my server that was working fine.
Also I use WordPress and its page builder + Elementor to build my site.
I also Disabled Rocket Loader as it was causing a lot of glitchy and unresponsive visuals on my site.

Thank you for feedback.

Yes, it seems there is some issue.
Kindly, see below article which is related to the Rocket Loader from my suggestion to disable it, or disable it using Page Rules:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.