Short Audio Clips not Playing

I have a website for learning foreign languages and we have lots of short 30 to 60 k. audio files that people listen to as they learn Spanish or another langauge.

This has worked well for years. When we tried to use Cloudflare, these clips would often (but not always) not play completely. Much of the time (but not all the time) they would start to play and then just stop.

We could download the clips manually just fine and the files were completely there and not corrupted.

When we switched back to our old DNS the problem went away.

I’m guessing that this is not the first time someone has had a problem like this.

How can I go back to using Cloudflare and not have this problem?

The problem should have been debuged and analysed while it occured so that we would have some info about what exactly is wrong, also a testlink where the problem occures would be good.

But please also keep in mind that CloudFlare (by its terms) is forbidding to use it for anything else, then delivering “standard” web-traffic which belongs to any normal website. Audios are strictly excluded from this. Please have a read here:

Use of the Services for serving video or a disproportionate percentage of pictures, audio files, or other non-HTML content is prohibited, unless purchased separately as part of a Paid Service or expressly allowed under our Supplemental Terms for a specific Service. If we determine you have breached this Section 2.8, we may immediately suspend or restrict your use of the Services, or limit End User access to certain of your resources through the Services.

I don’t know what a disproportionate percentage of audio files would be. These are 30 to 60 k files, they get downloaded once and then cached in the users browser.

We designed our system to work well on old dialup links so the pages are quite small by 2021 standards even when you count all our audio files.

But indeed they are audio files.

I certainly don’t mind going to the more economical tiers of Cloudflare’s pricing plans if I can get it to work. I do like the idea of using a content delivery network.

We can hope that someone will have some ideas of what likely can solve the problem, because I doubt that I am the first person to have this problem.

Should I try to contact customer service on this? Or have I done that by posting here?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.