Shared Universal SSL expired?

I am using the free plan to test a website with Cloudflare services.
A while I activated universal SSL and I was provided with a managed/shared universal SSL certificate.
I see now that it is expired. Wouldn’t these certificate renew automaticaly? I cannot get rid of it, I tried disabling Universal SSL, I tried removing the website from Cloudflare account and adding it again the next day, still that universal SSL certificate is bothering me. How can I delete it or let Cloudflare issue a new one?


What’s the domain?

It sounds like you’ve tried a few things, but give this a look also:

  1. the only cname set up was “www” and now is deleted.
  2. I turned universal ssl on and off a few dozen times already
  3. Name servers are set to Cloudflare from the begining
  4. the dns records are already routed through Cloudflare
  5. I will wait 24 hours after doing all the steps above, again.

To be more precise, should I have an expired certificate shown in the edge certificates tab even after Universal ssl is disabled?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.