Shared SSL Issues

My site is hosted with GoDaddy, but the DNS is with Cloudflare. I’m having a problem where the wrong version of my Wordpress site is served, and the formatting is all messed up. It happens when I use a flexible SSL, but not when the SSL is off. I have CPanel access for the backend. Is there any way to fix this, so I can continue to use a shared SSL? Also, an unrelated question, but does anyone know if the shared SSL works with .org domains? I know it doesn’t work with more unique ones like .art.

This is a screenshot of when I use a flexible SSL:

You can visit the site, http://www.douxdolci.com/, to see how it’s supposed to look (the SSL is currently disabled).

That really looks like a Mixed Content issue:

2 Likes

That’s a mixed content issue from your description. And, I suspect the .art site is also having mixed content issues.

Yes, it does.

Yes, it will work with .art, check for mixed content.

Here is a bit of background on mixed content, Community Tip - Fixing mixed content errors. Quick fix is to enable automatic https rewrites on the crypto tab. But, if the error is caused by scripts or css files, automatic rewrites won’t work 100%.

An easy way to identify mixed content from a script is to look for a small shield and red X on the address bar of google chrome. Select load unsafe script to see how the site would look once the error is corrected. Post back and share progress, this issue comes up frequently and there are a lot of resources here to assist.

Dont use Flexible in the first place.

You have a self-signed certificate on your server, so set that at least to “Full”. Better yet, install a properly valid certificate and set it to “Full strict”.

2 Likes

So it definitely seemed to be a matter of mixed content. Ordering a new Cloudflare SSL and taking the advice from sdayman solved the problem. Thank you all for the help

1 Like