SGV is not loading

None of my SVGs carry.

I will temporarily disable your proxy for my SVGs to return.

https://cdn.greatpages.com.br/arquivos/paginas_editor/greatsites-9455c60ed82871761f1c9ab65681eb4d.svg

Response headers are:

access-control-allow-origin: *
access-control-expose-headers: Content-Type
age: 24
cache-control: public, max-age=31536000
cf-cache-status: HIT
cf-ray: 5e7c58db1dcdf744-GRU
cf-request-id: 060195dcf20000f744dc1ac000000001
content-encoding
content-encoding: br
content-type: image/svg+xml
date: Sun, 25 Oct 2020 13:40:02 GMT
etag: W/“582619916c8df83d23fef3631a34bbd9”
expect-ct: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
expires: Fri, 08 Oct 2021 22:59:21 GMT
last-modified: Sat, 09 May 2020 22:25:53 GMT
nel: {“report_to”:“cf-nel”,“max_age”:604800}
report-to: {“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report?s=mCkZzB5F7Ba%2Fe49LacOO4Hod4Be3i%2FuVWXMvNZXsxZM2R57jXV9D%2F1tbHQj7o%2BVax1SdFKjuzf%2FYTC083pz2MQQDbFD1T53ezbZgnuff6imGtQd6Q3dvtW4wt1tcJ45xaWk%3D"}],“group”:“cf-nel”,"max_age”:604800}
server: cloudflare
status: 304
vary: Accept-Encoding
x-goog-generation: 1589063153166226
x-goog-hash: crc32c=qGg5vA==
x-goog-hash: md5=WCYZkWyN+D0j/vNjGjS72Q==
x-goog-metageneration: 3
x-goog-storage-class: REGIONAL
x-goog-stored-content-encoding
x-goog-stored-content-length: 914
x-guploader-uploadid: ABg5-Uy_A5b1C9n4JTMCr3lLYDz2CRqkCvR6u-qq1gUGlr4Q1DctryD0PDvHbMDM8VMK2icwGg8q6i8stob9xR_jrG3grQvxRA

The request headers are:

:authority: cdn.greatpages.com.br
:method: GET
:path: /arquivos/paginas_editor/greatsites-9455c60ed82871761f1c9ab65681eb4d.svg
:scheme: https
accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.9
accept-encoding: gzip, deflate, br
accept-language: pt-BR,pt;q=0.9,en-US;q=0.8,en;q=0.7
cache-control: max-age=0
cookie:
if-modified-since: Sat, 09 May 2020 22:25:53 GMT
if-none-match: W/“582619916c8df83d23fef3631a34bbd9”
sec-fetch-dest: document
sec-fetch-mode: navigate
sec-fetch-site: none
sec-fetch-user: ?1
upgrade-insecure-requests: 1
user-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.111 Safari/537.36

The SVG’s response looks like this:

�� ��c��e���&\�m�d��?���=�3��Eb�ׁ�p<�ڛ���6|�������ay�矷o�ʂ�* y�x����������Oakc��/���<Xt�~�_�
јC;?��]��}�$S؎�<X��__�Z���_yu�^�R�b��s,іg�6R6�
KM�������a�=hƙ�x����M�����ƌΙ���ce�<N�nW�+*�2 5������΄�3IT���O��^se�Ľ��!��s��a�LCf�Al<�P��C9��Un���=N`�RO �FϺ�i�``����w6��E��J�ܩ1��)E��9Hm�jVu(�R;aj�����(<>Üa�"2FV凕
��<�F�Us���9���x���?X�Zliш�17

Accessing the link directly appears this:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

I don’t see anything obvious, but since you’ve disabled Cloudflare, I can not test this or offer suggestions.

1 Like

Hi sdayman, how are you?

I will reactivate to be able to evaluate.

I have more than 6 thousand SGV with this bug.

It is active now.

Oddly enough, I still works in Firefox, but not Brave (Chrome) and Safari. I only tested Firefox when your site was off Cloudflare.

However, the SVG file does not pass this syntax checker due to encoding:

1 Like

Well, we have a very specific question in this case.

I think it’s nice to comment to see if this could be causing this problem:

At the moment, Cloudflare is for a CDN within Google.

Because we are migrating to CDN right now.

Could this be causing this problem?

Cloudflare should be pretty transparent, regardless of the source. So I’m not sure what is changing. It could be Brotli compression. And I don’t know why it would work in Firefox, but not the other browsers.

1 Like

I disabled Brotli compression and cleared the cache and nothing changed

Maybe there’s an @MVP around who can track down the issue.

2 Likes

This appeared now (with brotli disabled):

This page contains the following errors:
error on line 1 at column 1: Encoding error
Below is a rendering of the page up to the first error.

When I disabled brotli, content-encoding added GZIP. With brotli active, GZIP does not appear without content encoding.

https://storage.googleapis.com/greatsites-storage/arquivos/paginas_editor/greatsites-9455c60ed82871761f1c9ab65681eb4d.svg

Original…

I found out! Basically when cloudflare returns the file directly from Google CDN the problem occurs.

I tried to upload a file directly to Google Storage and connect to another domain and it worked perfectly.

I believe that Google CDN returns some different encoding and creates a communication problem. Because the file actually arrives at the end with an encoding problem (as I showed in the file response).

3 Likes

Well, I thought it was resolved, but it seems not …

Can you help me?

On Cloudflare:
https://cdn.greatsoftwares.com.br/arquivos/paginas_editor/pequenas/claiton-dieckson-lemes-f3ca3c97b1205021000c8fac7e5d01ef.svg

In Google Storage:

I already know exactly what it is, but it looks like some kind of cache on the Cloduflare side isn’t really looking for the new version.

The problem was, google storage was returning an empty content-encoding. When delivered by cloudflare, it returned 2 content-encoding: one empty and the other with brotli.

To solve it, I went to the google storage metadata and cleaned up the content-encoding. It resolved to images that had never been accessed through the dacloudflare link.

The problem I have at the moment is: the links accessed before the problem was solved, continue with the error (Even clearing the cache).

This one is appearing for me in Safari, Brave, and Firefox Nightly. First was a MISS with curl, then a HIT. That’s when I tried with the browsers. How is it for you?
https://cdn.greatsoftwares.com.br/arquivos/paginas_editor/claiton-dieckson-lemes-f3ca3c97b1205021000c8fac7e5d01ef.svg

1 Like

OMG! That’s it, I solved the problem in the main link and not in the thumbnails.

You saved me again.

1 Like

Well, now the content-encoding has been fixed in Google Storage but it is still not working in Cloudlare (I cleared the cache).

Google Storage:

Cloudflare:
https://cdn.greatsoftwares.com.br/arquivos/paginas_editor/pequenas/claiton-dieckson-lemes-f3ca3c97b1205021000c8fac7e5d01ef.svg

What generates the problem is the duplicated content-encoding (one empty and the other with br). The void was returning from Google Storage (which is now resolved).

The problem is that even clearing the cache in the cloud, her link still appears with duplicate content-encoding.

So I’m not clear on where things stand. The Claiton Lemes SVG logo still loads in all my browsers.

1 Like

It does not work here in any browser. I disconnected the wifi from my cell phone and connected by 4g and still without access.

A question … for you on the cloudflare link, does duplicate content-encoding appear?

Not that I can see. Brave (Chrome) sure gets more response headers than Firefox. (EDIT: Maybe not. I didn’t count…it just looks bigger with more line spacing in Brave)

1 Like

These are my headers. Content-encoding is duplicated.