Severe problems with super slow speeds occuring since 3 weeks on all my sites when visiting from Germany Berlin

With all my sites on Cloudflare, like, I am lately very often experiencing extremely slow download speeds that make the sites completely unusable a lot of the time. When I temporarily disable the caching, the sites tend to become usable again. However it seems the problem is limited to my location in Germany, since my analytics shows normal traffic volume, and I tried a service that shows how my sites are loading in different countries, and they all look fine, while here in Berlin, Germany, my sites are crippled since over three weeks. Cloudflare outage report shows nothing. Some other sites that use Cloudflare as well as the Cloudflare dashboard appear super slow as well when this happens. At times the sites load fast and normal as they should, but a lot of the time they are unusably slow. What can I do here? It is really frustrating this going on so long already.

1 Like

Same here. Also from Germany (but more near Ruhrpott). Backend on several of my websites behind Cloudflare super slow or not usable. Login into Cloudflare Account super slow, does not load, needs a lot of reload to finally load something. After disabling caching its working well.

Wordpress totally ■■■■■■ up which Cloudflare caching on.

Would be nice if the team would look into it

Yes, multiple Cloudlfare Pages projects have been super super slow over the last couple of weeks.

Related: Cloudflare Pages high TTFB for ~2 Weeks - #5 by madrigal

Also related:

Basically Cloudflare’s CDN seems to be extremely slow a lot of times, mainly within central EU region, for about 3 weeks now.

Also related

Have you tried disabling HTTP/3 (QUIC)? You can disable it in Cloudflare or in your browser. I also experienced intermittent hanging requests to my site (and Cloudflare itself) and ever since I disabled HTTP/3 in my browser, it hasn’t happened again. Looks like location-specific because when I ask others, they don’t experience it.

1 Like

Great @marte, that seems to have done it for me as well, disabling HTTP3 makes my sites load fast for me again.

The setting can be found in Cloudflare under Speed → Optimization → HTTP3

It fixes the problem, but reluctant to call it a solution and not sure what the implications of disabling HTTP3 are, the underlying problem should still be addressed by Cloudflare.


It seems that they’ve identified it before here and is supposed to be already resolved, but maybe not in every location or configuration.

That issue was referring to Chrome, right?

I’m still able to reproduce the issue on multiple other browsers (like Safari) and devices (desktop+mobile). Pretty sure the problem is client-indepentent.

If you can still reproduce, could you capture a netlog dump from Chrome (should also work for any Chromium based browser):

And DM me - I’ll share it with our Protocols team to take a look.

Sorry for the noob question, but how can I DM you?

Also have you seen this: Cloudflare Pages high TTFB for ~2 Weeks ?

I’ve opened a DM thread with you just now, so you can share there.

Also, for bonus points if you can still reproduce and can provide a netlog dump, it would be great to launch Chrome again with --disable-quic command switch (you can also do this via [KB6757] Disable QUIC protocol in Google Chrome browser ) and try again to reproduce and supply another netlog.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.