Setup WARP in fedora 34

I wanted to install Warp in my fedora workstation however when i tried to do so . While adding the repositories i get errors . help me figure this out

the package documentation says there is support for version 8.x however when i use the specified command replacing the version as 8 i get the following 404 error

Retrieving http://pkg.cloudflare.com/cloudflare-release-latest.el8.rpm
curl: (22) The requested URL returned error: 404
error: skipping http://pkg.cloudflare.com/cloudflare-release-latest.el8.rpm - transfer failed

and when i specify version as 7 i get

Retrieving http://pkg.cloudflare.com/cloudflare-release-latest.el7.rpm
error: Failed dependencies:
	redhat-release is needed by cloudflare-release-2.0.0-1436297086.el7.noarch

It should be all the same for the OS using Yum package manager : https://developers.cloudflare.com/warp-client/setting-up/linux

sudo yum install cloudflare-warp

Feel free to share your experience with Fedora 34 to us!

1 Like

Im using fedora 34 and try to add repository with sudo rpm -ivh http://pkg.cloudflare.com/cloudflare-release-latest.el7.rpm

but got error message

Retrieving http://pkg.cloudflare.com/cloudflare-release-latest.el7.rpm
error: Failed dependencies:
	redhat-release is needed by cloudflare-release-2.0.0-1436297086.el7.noarch

the package documentation says there is support for version 8.x however when i use the specified command replacing the version as 8 i get the following 404 error

Retrieving http://pkg.cloudflare.com/cloudflare-release-latest.el8.rpm
curl: (22) The requested URL returned error: 404
error: skipping http://pkg.cloudflare.com/cloudflare-release-latest.el8.rpm - transfer failed

and when i specify version as 7 i get

Retrieving http://pkg.cloudflare.com/cloudflare-release-latest.el7.rpm
error: Failed dependencies:
	redhat-release is needed by cloudflare-release-2.0.0-1436297086.el7.noarch

I installed

sudo rpm -ivh http://pkg.cloudflareclient.com/cloudflare-release-el8.rpm

Then I changed in /etc/yum.repos.d/cloudflare.repo the baseurl to “8” baseurl=https://pkg.cloudflareclient.com/dists/8/main/binary-$basearch

to be able to dnf install cloudflare-warp.
seems to work on my Fedora 34.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.