Setup subdomain www is not working

Hi all,

I deployed my project online and set up my custom domain for it, and I wanted to add the subdomain “www” for my website, which I did, but the website shows “Connection timed out, error code 522”.

I searched online, then I tried to add “@” for the recode, but it says “An A, AAAA, or CNAME record with that host already exists…”. I checked my original DNS and deleted all the records there, still got this error, did I miss anything, or what other step do I need to do? to make my subdomain work?
(btw, this domain was used in Shopify, and I removed it from the Shopify domain setting already)

Thank you for the support

A record for www subdomain already exists. It is a the bottom of the screenshot.

As you are using Pages, check out this documentation on how to correctly add custom domains to a project

Hi there, thank you for the quick reply, yes, I added the www at the bottom, but my website: wwwdigitalinsightmktgcom is not connected, and shows the connection timed out. I even tried removing the www one and adding @ as the root, still had that already existing error.

But I will read the docs first, see if I can figure it out, Thanks!

1 Like

If you can’t figure it out after reading the documentation above, I’ll happily provide you with further direction.

1 Like

That would be great, thanks in advance!

Since the apex domain has been added and working correctly already, I think this guide would be more appropriate if the goal is to redirect the www subdomain to the apex domain:

Hi GeorgeAppiah,

Thanks for the reply, and I tried to add either A with IPv4 or AAAA with IPv6, but both showed the “CNAME record with that host already existed”, I believe it’s the www one.

Still not working :frowning:

Hi there,

I enabled the DNSSEC from my registrar, but this doesn’t help either, wondering what else I can do.

You need to delete the existing CNAME record for www before you can add the A or AAAA record. You can’t have both CNAME and A records for the same name!

DNSSEC does nothing in this instance.

Follow the advice given by @GeorgeAppiah

Hi there,

I see that your apex is working without www. , but with www is outputting a 522, this is due to your host not answering requests for www..

There are 2 ways of solving this:
1 - On your dashboard go to RulesRedirect Rules and create this rule:


2 - Go to Workers & PagesOverviewdigita#####Custom domains and add side by side with the custom domain you already have there.

Take care.

1 Like

Thank you very much!!!
Both ways work for me!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.