Setup on MikroTik RouterOS?

hello, i have a problem set on my RouterBoard

i used below script on terminal, which is work with opendns. But when i’m use it with Cloudflare DNS i can’t do browsing, etc. i can only ping

/ip dns
set allow-remote-requests=yes servers=1.1.1.1,1.0.0.1

/ip firewall nat
add action=dst-nat chain=dstnat comment=Cloudflare dst-port=53,5353 protocol=tcp to-addresses=1.1.1.1 to-ports=5353
add action=dst-nat chain=dstnat comment=Cloudflare dst-port=53,5353 protocol=udp to-addresses=1.1.1.1 to-ports=5353
add action=dst-nat chain=dstnat comment=Cloudflare dst-port=53,5353 protocol=tcp to-addresses=1.0.0.1 to-ports=5353
add action=dst-nat chain=dstnat comment=Cloudflare dst-port=53,5353 protocol=udp to-addresses=1.0.0.1 to-ports=5353

i have rebooted my RB, but nothing happen. please help?

Your dst-nat’ing to port 5353 which 1.1.1.1 or 1.0.0.1 does not respond too…

/ip dns
set allow-remote-requests=yes servers=1.1.1.1,1.0.0.1

/ip firewall nat
add action=dst-nat chain=dstnat comment=Cloudflare dst-port=53,5353 protocol=tcp to-addresses=1.1.1.1 to-ports=53
add action=dst-nat chain=dstnat comment=Cloudflare dst-port=53,5353 protocol=udp to-addresses=1.1.1.1 to-ports=53
add action=dst-nat chain=dstnat comment=Cloudflare dst-port=53,5353 protocol=tcp to-addresses=1.0.0.1 to-ports=53
add action=dst-nat chain=dstnat comment=Cloudflare dst-port=53,5353 protocol=udp to-addresses=1.0.0.1 to-ports=53

if you are use dns for internal network use. you don’t need “set allow-remote-requests=yes”
because of that can anyone external will use you ip as dns than your internet link could be slow.

Current RouterOS Firewall default configuration doesn’t allow this.
I also suggest to use “NAT REDIRECT” feature, it will redirect any autonomous DNS resolution from clients to the Mikrotik and then to Cloudflare