Setting up SSL >1.Log in to your Enom account

Hi

im trying to set up an SSL cert but step 1 asks me to login into my Enom account but i don’t have one!

Do these set up steps mean i should login into my DNS of my current hosts and change the name servers there or is this a new feature where we have to have an Enom account to proceed with an SSL via Cloudfare ?

All Best
Dan

Complete your nameserver setup

isleofwightnewsdaily.com is not yet active on Cloudflare.

  1. Log in to your Enom account

Remove these nameservers:

ns1.swebhosting.co.uk

ns2.swebhosting.co.uk

2. Replace with Cloudflare’s nameservers

Nameserver 1

eric.ns.cloudflare.com

Click to copy

Nameserver 2

tara.ns.cloudflare.com

Click to copy

Save your changes.

You need to log into the account of your domain registrar; the place you registered your domain name. On the interwebs at least Enom is listed as the registrar.

Domain Name: isleofwightnewsdaily.com
Registry Domain ID: 1799585796_DOMAIN_COM-VRSN
Registrar WHOIS Server: WHOIS.ENOM.COM
Registrar URL: WWW.ENOM.COM
Updated Date: 2019-04-30T10:33:18.00Z
Creation Date: 2013-05-07T14:57:00.00Z
Registrar Registration Expiration Date: 2020-05-07T13:57:06.00Z
Registrar: ENOM, INC.
Registrar IANA ID: 48

Ah ok i see my confusions since i have never heard of them and registered via UK2.net but they must outsource their registration to enom.

So i take it i should go follow those instructions but at my UK2.net dash board and not enom directly i presume ?

Thanks for your help!

All Best
Dan

ps - also i just received email saying process complete and now active but the site says its still insecure, i take it thats just a question of waiting 24 hours or so for dns propagation ?

Hi @dan6,

Looks to me like your Cloudflare setup is OK, however there is a redirect from HTTPS to HTTP

>>> https://isleofwightnewsdaily.com/

> --------------------------------------------
> 301 Moved Permanently
> --------------------------------------------

Status:	301 Moved Permanently
Code:	301
Date:	Fri, 16 Aug 2019 09:55:50 GMT
Content-Type:	text/html; charset=utf-8
Connection:	close
Set-Cookie:	paperlisession=5dad433119c36d20490eacdf939fdadf; path=/; HttpOnly
Location:	http://isleofwightnewsdaily.com/
X-UA-Compatible:	IE=Edge
Cache-Control:	no-cache
X-Request-Id:	1020e3958b151545745b5034ffc76783
X-Runtime:	0.005714
X-Rack-Cache:	miss
X-Pallet-Id:	prod-front4
X-IPLB-Instance:	4624
Expect-CT:	max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
Server:	cloudflare
CF-RAY:	507288ed0e22d725-FRA

I’m guessing this is on the server somewhere (unless you have configured it under ‘page rules’ in Cloudflare).

ok thanks for the info but seems strange since i havn’t done anything else beyond the cloudfare process, such as setting up a redirect, any ideas what i need do to change or diagnose whats going on here ?

all best
dan

To start off with, can you pause Cloudflare on the site and let us know when you have done that so we can check the redirect again. This will confirm if the redirect is coming from Cloudflare or directly from the server.

You can pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions.

Asked that because I was on mobile at the time. Back on desktop now so no need to pause it. I have tested it directly to your server (bypassing Cloudflare) and the redirect is there:

image
The blurred IP address should be that of your server which I went directly to.

As you can see from the screenshot above, the 301 comes directly from there so you will need to look into that further. Maybe contact your hosting provider for assistance?

ok great thanks i have now done that (paused it)

1 Like

Great, that confirms my post above:

ok so i can unpause it now, to resuem propagation ?

then i go to my host and look into the redirects and try sort that out there ?

all best
dan

Yep :+1:. Your host may prefer to troubleshoot the redirect with Cloudflare still paused.

ok cool although weirdly i can only see a redirect from isleofwightdailynews to isleofwightnewsdaily, so as far as i can see there isnt a redirect on isleofwightnewsdaily (as per attached screengrab) or is that something to ask my host about not you ?

all best
dan

The redirect I see is https://isleofwightnewsdaily.com --> http://isleofwightnewsdaily.com/

Which, like you say, is not showing up there. Your host may have configured it in the background as you don’t have a valid SSL cert on the server for that domain. They should be able to help with this one!

ok thanks i have asked them via a support ticket

but just to confirm no there wont be a valid ssl certificate there since that’s what i’m trying to do via cloudflare (set up a valid ssl certificate) and i have now changed the dns from host servers to cloudflares as per the instructions, so thats all fine isn’t it ? or are you saying i need some sort of SSL on my hosts servers too ? I thought the point of all this is that i don’t need to do that since i use cloudflare for that? So i presume im misinterpeting it and the above is correct?

thanks again

Cloudflare has different ‘SSL modes’, the ones to look at are ‘Full’ and ‘Full (strict)’. ‘Full (strict)’ is more secure, but requires a valid certificate on the server. ‘Full’ is less secure but you can have a self-signed/not-valid certificate on the server which is what you seem to have. Your host should be able to clarify what the redirect is and why it’s there.

ok great thanks

i have since found this on the hosts help pages:
https://support.paper.li/hc/en-us/articles/207157497-Ensuring-your-paper-uses-https?mobile_site=true

But i seem to have followed all that i think and its doesn’t mention anything about extra redirects but i have sent them a support ticket

1 Like