Setting up new accout with HTTPS


#1

I have a GoDaddy account and had an SSL certificate. I added cloudflare as a CDN, changed DNS at godadday and now when I go to my web page, it has the https in red with a line through it and I cannot access my website. I have searched for hours on help with this and changed all kinds of setting in Cloudflare. Where should I go?


#2

A clairvoyant might be a good idea :wink:


#3

Tried it already. Now I get the 429 too many requests…


#4

It was working perfectly before with out the SSL and then I added that to my GoDaddy site and things are not working since then.


#5

Help us to be able to help you.

Would you mind telling us the domain?


#6

What did he say?


#7

The clairvoyant should have told you that. :grin:

  1. Did your GoDaddy site have SSL on it before you added Cloudflare?
  2. What’s your SSL setting here? (If you say “Flexible”, you’re going to hear a collective groan, as it’s not very secure)
  3. @markmeyer just beat me to asking what your domain is.

#8

They used to be so much better in the good old days :frowning:


#9

nvigolf.com is the domain.

I had the site on Cloudflare the past couple of days and was working fine.

I added the SSL at GoDaddy today. Added the account to Cloudflare again. SSL certificate is active, but I was getting the red line through the HTTPS and could not get to the account. I have done nothing, and now I get the 429 redirects


#10

Redirection loop.

Let me guess, Flexible mode, Wordpress, no SSL certificate, but SSL required server-side


#11

My godaddy account did not have ssl the first time I put it on cloudflare, and everything worked great. superfast!

I added the SSL today and things did not work, so I removed my site nvigolf.com from Cloudflare and added it again now that it has the SSL on GoDaddy.


#12

SSL is on full and the toggle for always use HTTPS is on


#13

And now its working suddenly.


#14

Did you make any change to either configuration in the past ten minutes?


#15

Since you have an SSL cert at GoDaddy, go ahead and try SSL Full (Strict). That will make sure the host cert is valid.


#16

No, not since I posted.


#17

I have changed it to strict.


#18

Should the always use HTTPS be set to on?


#19

Full strict is the better choice but shouldnt make a difference in this particular case.

There was a redirection loop and now it suddenly works. If you say you didnt make any changes it could only have been a genie :wink: Impossible to say at this point, but it works now, right?


#20

Yes, it works now. I have another site I want to move over as a second account from godaddy as well, so I was trying to figure out what might have gone wrong before I move it.