Setting up DNS, hosted at Mochahost (Cloudflare Partner)

Hi guys,

First time posting here, I hope you can help me.

I received an e-mail from Cloudflare saying that I should update my nameservers at my registrar. However, I am hosted at Mochahost (a CloudFlare partner) and I have put their DNS at my registrar. My Mochahost account has DNS pointed to CloudFlare.

Should I point registrar directly to CloudFlare? If yes, do I have to change something on Mochahost or it will work right away?

When I am logged in my CloudFlare account I see in the “Home” section that my domain is active and I can change settings without problem. Also, in DNS section I can see “Partner hosted zone”. Your DNS zone file is hosted by MochaHost , a Cloudflare partner. Manage your DNS records at their website.

However, if I click on my website on CloudFlare and go to “Overview”, it tells me in the menu at the right – Domain Registration, Registrar : Unknown with a link to Manage Domain. If I click on Manage Domain I see my domain name with an orange dot “Not on Cloudflare”

All this makes me a little confused

Please tell me what is the better Performance option since I want my website to be as quick as possible.

Hope I am clear enough.

Thanks in advance

Email looks like this

Hi @swebby182, your question seems clear, in reading it, however, it seems our dashboard could be a lot more clear! Sorry. Edit - Sorry about that email, it is really confusing and not correct.

If you’re with a partner and they manage your DNS records, you don’t need to change them. We call it a “partial setup”, if you add a site directly via Cloudflare we call it a “full setup”. If you can share the name of the domain in question, I can tell you the type of set up we show internally, although I am pretty sure it will read as partial via a partner based on what you’ve posted. Edit - Dug in and found that yes that is the case, you’re on a partial setup via a partner as you indicated.

I don’t think either setup would affect performance positively or negatively.

1 Like

Hi cloonan and thanks for the quick reply.

The domain is quelemeilleur dot fr

They (Mochahost) also told me they enabled Railgun but every resource I see in google Developper mode is always showing

cf-railgun: direct (starting new WAN connection)

I think something might be misconfigured?

Thank you, I’ve let the team know about the email. I do show railgun as active on the domain effective midday yesterday. Note that our partner needs to troubleshoot railgun issues as Support cannot, but what are you seeing on the site that looks off?

1 Like

I checked on the web to be sure that railgun was working, because I didn’t see any improvement in speed when testing on Gmetrix (exactly the same). I was hoping a little improvement at least.

So what I found in cloudflare support is that normally chrome developper mode should show something like

Intended Behavior

Here is a typical sequence of requests where the initial connection establishes the WAN, then subsequent requests are optimized while the WAN is open between the Railgun Sender and Listener:

Cf-Railgun: direct (starting new WAN connection)
Cf-Railgun: 6a622d1e98 0.02 0.001751 0030 3350
Cf-Railgun: c562e934d3 0.02 0.002268 0030 3350
Cf-Railgun: 342a904d9c 0.02 0.002070 0030 3350
Cf-Railgun: c3f365ab80 0.02 0.004062 0030 3350

Mine is always showing
Cf-Railgun: direct (starting new WAN connection)
Cf-Railgun: direct (starting new WAN connection)
Cf-Railgun: direct (starting new WAN connection)
Cf-Railgun: direct (starting new WAN connection)
Cf-Railgun: direct (starting new WAN connection)

My Time To First Byte TTFB is mediocre and I can’t find why so I’m digging.