Setting up a subdomain for a worker

Hey there!

I’ve setup a worker, which is named (for example) “myworker” and I want it to be accessible from myworker.mydomain.com. I’ve added the proper route (thus I can find the worker under my site name) and also added an “AAAA” record pointing to “100::”.

Still, the custom subdomain name is not viable:

I need help in properly setup the DNS records for mydomain.com to make the worker accessible via that subdomain name.

Thank you!

Stefan

Could you please also add a dummy IPv4, like 192.0.2.1 for the same DNS entry?

Hi M4rt1n! Thank you for trying to help me.

Of which type this new DNS entry should be?

IPv4 = A
IPv6 = AAAA

So the new type shall be a A entry

I have added:

  1. Type: A, Name: mysubdomain, Content: 192.0.2.1, Proxied, TTL: Auto
  2. Type: AAAA, Name: mysubdomain, Content: 100::, Proxied, TTL: Auto

Unfortunately, I have the same errors as in the origin post.

Could you share your DNS entry section as a screenshot, so I can have a look at them?

REMOVED the link to screen capture for security reasons.

In Cloudflare Pages setting what exact domain are you using?

It is skill4ltu.eu

This domain works when I call it.
If you are talking about the moe.skill4ltu.eu this domain does not seem to be setup in Cloudflare Pages.

moe.skill4ltu.eu should be the worker I am trying to use.

I sadly am not very familiar woth Workers, sorry. You will have to wait untill some peopel with more worker knowledge will reply.

I thought its a normal 1001 error, but it is a JSON error response, not the typical 1001 error:

{"status":"error","error":{"num":1001}}

Thank you very much for your time, M4art1n! I really appreciate you’ve tried to help me. I’ve asked the support first (being on a PRO Plan), but they didn’t respond in 6 days now… so, I’ve tried the community.

<3