Setting up a Redirect wildcard

Hi Guys,

I need some assistance please…

I would like to know how to add a Wildcard redirect on something. I am assuming this is what’s needed. I am not an expert in this field but I have done some searching and just not sure how to set this up.

I have a site on Kajabi that’s using Cloudflare and currently the blogs are setup this way www.mysite.com/blog/myblogname, so I will call each blog /1 , /2, /3 and so on but I don’t want it to say /blog is there a way to have a forwarder to remove the /blog? My initial outcome would be www.mysite.com/1

Hope that makes sense and that someone can assist me.

Thanks so much,

Jessica

I think you are not talking about a redirection, but you just want your blog being hosted on another URL like:

www.mysite.com/1/ ==> Blog 1
www.mysite.com/2/ ==> Blog 2
www.mysite.com/3/ ==> Blog 3

Or do you want to redirect from:

www.mysite.com/1/ ==> www.mysite.com/blog/1/
www.mysite.com/2/ ==> www.mysite.com/blog/2/
www.mysite.com/3/ ==> www.mysite.com/blog/3/

?

If you want to achive the first thing then CloudFlare will not be able to directly help you there as this should be achived by changing server and application settings/configurations.

So the question is:

  1. do you want to change the baseURL of your Blogs
  2. create a redirect that goes like this:
    www.mysite.com/1/ ==> www.mysite.com/blog/1/ and redirects all visitors from www.mysite.com/1/ to http://www.mysite.com/blog/1/

I guess this is something you want to achieve.

1 Like

Hey @M4rt1n thanks so much for your response.

The blog is on Kajabi and by default the url adds the /blog. I want to remove the /blog

www.mysite.com/blog/1 Redirect to www.mysite.com/1

is this possible?

1 Like

Oh awesome @erictung let me give this a try! :slight_smile:

2 Likes

Yes this is possible just the way @erictung has described it. But care. If the URL www.mysite.com/1 is not responding with the Blog it will most probably break your site.

First you should move your Blog1 in the subfolder “1” of basedir of you rootdomain.

PLEASE first try with 302 and not with 301 as it is “premanent” (cached on Browser untill you wipe cache)

2 Likes

Okay awesome thanks so much for your help. I will let you know if its not working lol. Hopefully it does :slight_smile:

2 Likes

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.