Setting noindex to a specific subdomain

I have a subdomain (app) that uses a CNAME to point the subdomain to the proxy for mp-app dot com.

I looked at this thread: 328751

It seemed obvious how to do it for one subdomain, but according to Google Search, my pages are still indexable. I’ve tried the host as app dot mydomain and app dot mydomain /* Neither seem to have worked. What am I doing wrong?

Cloudflare can only modify the headers of orange-clouded (proxied) traffic. The DNS entry is grey-clouded so most Cloudflare features including header modification are bypassed.

Okay. I’m still not clear on what can and can’t be proxied, but I’m guessing this is something that can’t be. Bummer.

I seem to recall having to change from Proxied to DNS because it wasn’t working.

What happened when you tried to proxy it? There are a number of things that could have gone wrong, but first thing to check, make sure SSL Mode is set to Full(Strict), as “Flexible” can cause a redirect loop.

404 errors.
My mode is Full. Not the strict version, though. I don’t think my host has the certificates to do the strict.

I’ve set the mode back to Proxy to verify that is the full issue here. I need to let the DNS propagate.

Somehow in the overall evolution of how I have things set up, it does seem that the proxy works with the MyPhotoApp site proxy, and things are well; and now I can not have these little microsites be indexed.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.