Set up of heroku custom domain results in "There is nothing here, yet"

Hi, I try to set up my custom domain for my app on Heroku. My app is deployed on Heroku and working. However when I try to set up a custom domain on heroku and Cloudflare and then visit the custom domain, I get the ‘Here is nothing here, yet’ site.
Here is what I did:

  1. On Heroku’s app page I went to “Settings” → Add domain and enter my domain like this:
    my-domain-name.com. Then I go to “Next”, copy the DNS target and copy the shown link.
  2. On Cloudflare I have my custom domain added to Cloudflare. The Cloudflare name servers are set correctly, I get the message “Cloudflare is now protecting your site”.
  3. On Cloudflare I go to the DNS section and remove all shown A-records. Then I add two CNAME records:
    a) CNAME my-domain-name. com dns-target-from-heroku
    b) CNAME www my-domain-name. com

However, when I visit I always get the “There is nothing here, yet” Page from Heroku.
What am I missing? Any hints are appreciated.

I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.