Set up of email

There were no records showing for my domain so I created all the new records. The website seems to be working fine, but my emails are not working. Can anyone assist? Here is a screenshot of my records. I have followed all the tutorials and tried many variations.

You need to have autoconfig, imap, pop, relay and smtp DNS records :grey:

1 Like

and mail.

1 Like

Greetings,

Thank you for asking.

A bit from other perspective, I’d suggest you to double-check which of the below CNAME records are you using at your e-mail client such as MS Outlook, Mozilla Thunderbird, etc. and/or in your Web app or mobile phone e-mail app:

  1. CNAME imap
  2. CNAME pop
  3. CNAME relay
  4. CNAME smtp

As far as all of them point to mail.yourdomain.com, you could simply remove all 4 of them and just configure and use mail.yourdomain.com everywhere you’d be using normally.

  • seems like you could possibly just doing a nonsense overhead with DNS records after all …

I write that because from my experience in one particular case, the web hosting provider offered hosting/e-mail, but not the SSL for a sub-domain of the client.
Therefore, client had to use the hostname of the given VPS/server and have had some CNAME records including mail.clientdomain.com pointed to hostname.server.com.
What happened was MS Outlook was catching the autoconfig and autodiscover “by default”, therefore detected and used mail.clientdomain.com and alwas throw a warning and error about the SSL issue for the domain while connecting to the server to receive or sent out an e-mail.
Upon we removed them and changed his receiving and sending server to hostname.server.com all worked fine.

So, this might be one case, just to mention it as far as I don’t know if you’re having similar situation with a hosting/e-mail provider, or a setup since before so they’re left there standing “as-is”, or you’re using cPanel, or something else.

Nevertheless, as @Cyb3r-Jak3 and @i40west suggested, that should help you to solve your issue with receiving and/or sending e-mails while using Coudflare for your domain name.

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

I’d just like to drop here a suggestion as by checking below related article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

1 Like

Thank you! I resolved it now. My host gave me records to add that were not necessary. I went and looked at my other domain set up and copied what I had done there previously. Everything is working now.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.