Set Browser Cache TTL Page Rule for Homepage?

How do I set a page rule for my home page?

What is happening is that I think the Browser Cache TTL header is too high for the homepage as people need to hard refresh to see updates, so I want a rule for my homepage set to something like 5 minutes. Or even no caching for the homepage.

If I set a rule with the domain url, does that effect the entire site (ie example-com/)?

Also, does anyone know if page rules take precedence over the Cloudflare Wordpress APO?


This makes me think that this is not a Browser TTL issue, but one that stems from APO itself, or from APO being misconfigured.
Please notice that a hard reload, not just ignores local cache, but also bypasses APO cache and therefore, I believe it is an APO problem.

Before concealing the problem with adjusting the Browser TTL to any unrecommended value, I would like you to consider if the problem could be anything related to APO.

If the page is not updating, can you please instead of hard-reloading, just try to call the same page from an anonymous tab, as any anonymous tab does not have any local cache, but will receive the same APO cache.

If the anonymous tab will show the same old page, then APO seems to be the problem.
If the anonymous tab will show the updated page, then local caches are the problem.

1 Like

Okay, so I opened the page in a fresh tab and it showed no update, then I reopened another tab and it did show an update. Is that a Browser headers issue?

I also turned off APO.

Just tried it again and it took three tabs to see new content, so not sure what’s up.

Weirdest thing. My homepage wouldn’t update on Safari Iphone with a refresh. As soon as I turned APO off it did update. I’m using Wordpress Trellis theme, so wondering if there is a conflict.

Update: I am using the WordPress Trellis theme which has ExpiresDefault “access 1 month” in the htaccess which APO seems to conflict with for some reason. I removed that from htaccess and evertying seems to be working alright.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.