Session Affinity Not Working

The session affinity does not seem to work for a given load balancer. I have 3 servers but with more than one server enabled in the the load balancer a user will start a session on server 1, on a random request be moved to server 2 then on the next request the user will back to server 1.

This is super frustrating for customers and admins as people are in the process of checking out or doing some work that then restarts everything.

I have tried multiple different settings, I read Random session steering has a chance for the same IP to hit different origins, so i changed the session steering to Hash.

I have added health monitoring to servers, and get zero errors.

In order to fix this problem I am just pointing the Load Balancer to one server and while that works it defeats the purpose of having a load balancer and multiple servers.

I found a post from a few months ago describing the same issue but a few people said the problem is fixed for them now.

Is anyone else experiencing the issue? Or is there some setting that I can change to fix this?

I have had problems for months now trying to get session affinity working. I opened a ticket with Cloudflare, but the customer service is very slow to respond.

Hello there, Cloudflare had accepted this issue previously when other users too faced similar problems. Also, they had posted an update too where the issue was solved. Unfortunately, this was a internal issue and had to be rectified from their end alone. You may check the post ‘Load Balancer session not working correctly’. At the same time, you may open the support ticket.

After all this time Cloudflare support finally responded. The issue was there was no DNS record for www so Session Affinity did not work

The article describes “Currently Cloudflare only supports Session Affinity in “orange-cloud” (proxied) mode.”

The Load Balancer had proxy turned on but without the DNS record it would not work

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.