Service token for zero trust

Hi there, I am hosting a private app on zero trust and need Zapier integration.
To get passed the blockage i was reading i needed to create a service auth which i did.
It gives me a CF-Access-Client-Id: xxx.access
Header and client secret
CF-Access-Client-Secret: xxxa5ccb12e71a32b0
I also created an application policy and added the created service token as Include.

However when i make a request from Zapier with the client id and secret as headers i still get the auth screen.

I tested it from some api testing kit and got the same result.

Hey, Welcome to the community!

Is your new application policy using Action: Service Auth? If it’s Allow, it’ll still force an identity/login process

For example, you might have one Service Auth policy including the service token, and another Allow policy based on specific emails/rules on identity providers rules.

Aha! That terminology was confusing to me indeed!
I changed it to action service auth and it started working like a charm.


-------- Oorspronkelijk bericht --------

1 Like