Servers at acfr.usyd.edu.au not resolving on 1.1.1.1

Hello,
since some time last week servers under acfr.usyd.edu.au (e.g. opium.acfr.usyd.edu au) have stopped resolving on 1.1.1.1. They still show up correctly on other dns servers such as 8.8.8.8. I couldn’t find any obvious issues that should prevent the resolving from happening correctly so I’m posting it here.

Please see below for the output of some diagnostic commands.
The only failure I could find was that one of the four dns servers for usyd.edu.au is unresponsive. But since the other three work fine it should work alright.

$ dig opium.acfr.usyd.edu.au @1.1.1.1

; <<>> DiG 9.16.1-Ubuntu <<>> opium.acfr.usyd.edu.au @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 9926
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 16 ("..")
;; QUESTION SECTION:
;opium.acfr.usyd.edu.au.		IN	A

;; Query time: 7 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Mon Nov 01 10:51:25 AEDT 2021
;; MSG SIZE  rcvd: 57

$ dig opium.acfr.usyd.edu.au @1.0.0.1

; <<>> DiG 9.16.1-Ubuntu <<>> opium.acfr.usyd.edu.au @1.0.0.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 61441
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 16 ("..")
;; QUESTION SECTION:
;opium.acfr.usyd.edu.au.		IN	A

;; Query time: 4099 msec
;; SERVER: 1.0.0.1#53(1.0.0.1)
;; WHEN: Mon Nov 01 10:51:34 AEDT 2021
;; MSG SIZE  rcvd: 57

$ dig opium.acfr.usyd.edu.au @8.8.8.8

; <<>> DiG 9.16.1-Ubuntu <<>> opium.acfr.usyd.edu.au @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21613
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;opium.acfr.usyd.edu.au.		IN	A

;; ANSWER SECTION:
opium.acfr.usyd.edu.au.	3600	IN	A	129.78.210.237

;; Query time: 11 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Mon Nov 01 10:51:39 AEDT 2021
;; MSG SIZE  rcvd: 67

$ dig +short CHAOS TXT id.server @1.1.1.1
"SYD"
$ dig +short CHAOS TXT id.server @1.0.0.1
"SYD"
$ dig @ns3.Cloudflare.com whoami.Cloudflare.com txt +short
"118.208.241.162"
1 Like

Adding the diagnostic tool url. All the remaining information is in the original post already.

It looks like you’ll just be going through SYD. As I don’t have an easy way to test anything other than LAX, it’s difficult to pinpoint how widespread this is. And I can’t imagine that IPv6 or the .2/.3 will return anything different for you.

; <<>> DiG 9.10.6 <<>> opium.acfr.usyd.edu.au @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45334
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;opium.acfr.usyd.edu.au.		IN	A

;; ANSWER SECTION:
opium.acfr.usyd.edu.au.	3600	IN	A	129.78.210.237

;; Query time: 659 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Sun Oct 31 17:49:26 PDT 2021
;; MSG SIZE  rcvd: 67

Yes, 1.1.1.2 and 1.1.1.3 show the same issue on my end.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.