Server Let's Encrypt SSL error

Hello,
I have a Ispconfig server (Perfect server ubuntu 20.04 following the howtoforge manual) where the config page is servet at server1-domain-com:8080 (not the real domain). It generated the Let’s encrypt certificate for server1-domain-com and it worked out of the box. I also have e Let’s encrypt cert for domain-com.

Then i setup my domain with Cloudflare (name servers and proxy) with the corresponding A records for domain.com and server1 host.

Cloudflare generated an SSL let’s encrypt universal certificate for *.domain.com and domain.com.

If i config SSL as Full or Strict, trying to access to server1-domain-com:8080 gives on chrome ERR_SSL_PROTOCOL_ERROR and on firefox the SSL_ERROR_RX_RECORD_TOO_LONG; but domain.com and server1.domain.com works and shows the *.domain ssl certificate.
If i left it as DNS only it works.

can you help me please?

8080 isn’t an HTTPS port. It’s used for HTTP.

Thankyou sdayman, i changed the port to 8443 and now it works with full strict.
Only that now accessing to server1.domain.com gives error 526. Iw ill check it. Thank you very much.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.