Serious performance issues


#1

My site is taking an extremely long amount of time to load up when using Cloudflare

I went through the KB article (200172856-My-website-is-slow-or-having-performance-issues) and the results are:

I tried disabling/pausing CF and it all seems fine then

Any thoughts would be appreciated

Thanks


#2

It’s timing out for me, which is the same problem noticed by WebPageTest… Can you try toggling your A records for root and www to :grey:?


#3

That’s a lot of stuff that’s just not loading. Do you have access to your server logs? The 522 errors are because your server is not responding to those requests. Your hosting company might be able to help track this down.


#4

Thanks for the advice. They both are :grey:

I saw the 522s but I cant work out why they happen. When the CF is paused, they get served from the origin successfully.


#5

Currently it is on Cloudflare and it does load. It is not very fast but I’d attribute that probably rather to the origin server.


#6

They are most definitely not.

dig www.whatsamsawtoday.com @1.1.1.1

; <<>> DiG 9.10.6 <<>> www.whatsamsawtoday.com @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43718
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1536
;; QUESTION SECTION:
;www.whatsamsawtoday.com.	IN	A

;; ANSWER SECTION:
www.whatsamsawtoday.com. 264	IN	A	104.18.42.166
www.whatsamsawtoday.com. 264	IN	A	104.18.43.166

;; Query time: 12 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Sun May 27 22:08:40 CEST 2018
;; MSG SIZE  rcvd: 84

#7

This topic was automatically closed after 14 days. New replies are no longer allowed.