Sending Emails to Gmail Users

Hello Cloudflare Support,

I am contacting you regarding persistent email delivery failures that seem to be linked to SPF checks. Below is a brief overview of the problem

Are you only sending emails out through Strato?

If you can confirm that, the solution is to use this SPF record:

Type: TXT
Name: @, or
Content: v=spf1 -all
TTL: Preferably set it to something like 12-24 hours, as mail related records likely do not change that often.

Make sure you replace the current record with that information, as you cannot have two (or more) with the same “Name” (label).


Thanks, email is working
However the page is not available anymore, idk why

Does it happen because of the spf change?

No, these changes are completely irrelevant to your website (and it’s function).

It seems like your website is configured properly to be using, but NOT

Visiting seems to work just fine, - however, some settings on your website with Hostinger is redirecting visitors to after a little while.

As is not configured properly, and currently provide a 525 SSL handshake failed error, every visitor will after a few seconds, or so, after they have been redirected, end up with the error (even when initially going to the variant).

The redirect isn’t just a normal HTTP redirect, but appears to be done via some of all the JavaScript your website sends to it’s visitors, but tough to look in to where exactly, as it is has all been minified.

But that redirect is coming from your website and it’s configuration on Hostinger, and has nothing to do with Cloudflare, or the adjusted SPF.

What exactly is your DNS record for (type AAAA, A and/or CNAME) set to?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.