"Select a Plan" doesn't work


#1

“Select a Plan” doesn’t work on new site setup when I choose free plan. The page is just stuck on that screen after I submit. I have been trying for a couple of days. See the image below. What should I do?


#2

I was able to proceed. Check attached image.


#3

The plan selection works for me as well. Which browser are you using? Anything that could block site elements, ad or script blocker?


#4

If there are no ad or script blockers as @sandro mentioned, clear your cache (all time) and try again


#5

The issue happens on Safari when I click “Purchase”. No script or ad blocker, no extension that injects scripts into the page, cache cleared. I even tried in a private window.

I just tried on Chrome and it works though. Thanks everyone who replied!


#6

Same problem here, I don’t think the solution should be using Chrome, please fix CF


#7

Chrome-only should definitely not be a solution, but it works on Firefox and Edge too. Are you using Safari? That might be a bug in Safari then. If you can debug what the issue is, I am sure that might help finding a workaround.


#8

OK I forgot to test in Safari Technology Preview. I’d be happy to do so but it’s difficult to reproduce without adding a domain to CF.


#9

Just add any random domain, you can always delete it.