Sectigo SSL & Cloudflare not working


#1

Hi,
I’m desperately trying for days to get my webserver with Sectigo SSL cert to work properly. Activating “Strict” simply shows: This setting was last changed 3 days ago
Whatever setting I try (incl. URL redir) it won’t work. If I surf manually to https:// then it works. We got a Sectigo (ex Comodo) cert.
Any help/clues?
Thanks!


#2

What does not work? That certificate will be on your server and will be used to secure the connection between your server and Cloudflare and if it is properly configured I’d assume it will work.

Whats the exact issue and whats your domain?


#3

What doesn’t work: SSL cert not shown in “Crypto”

Directly typing the URL into the browser like this: https://www.test.com or https://test.com will work wo/ any problem

I also tried “Page rules” and forwarding all “http” traffic to “https” to no avail.

Pretty clueless right now :wink:


#4

Can you post a screenshot?

And again, without your domain it is impossible to say anything.


#5

www.toscano.ch


#6

What is not showing there?

And, your domain does not proxy through Cloudflare to begin with, so any TLS settings are not effective.


#7


#8

Precisely.


#9

sorry, can’t post that quick: new user limitations!


#10


#11

To clarify, you do want to proxy through Cloudflare? If so you need to switch those records to :orange:


#12

Once I enable proxying (CDN / DNS) I get this error:

grafik

If I disable “the orange cloud” and enter https manually (with or without www.) it works


#13

Can you post a full screenshot of your Crypto section? It might be that your Cloudflare certificate hasnt been issued yet.


#14


#15


#16


#17

There is no edge certificate issued. You need to enable universal SSL at the bottom of the page.


#18

Great, I will try this right away! Thanks.


#19

Dear Sandro,

Sorry for late reply, but the forum software didn’t allow me to post so much for the first day.

Thanks a bunch, it works like a charm! (IOU a beer)

Greetings!