Script Not Working Unless on Development Mode

Hello. I have a web app installed on my server located here:
https://www.crustpizzaco.com/onboard-location-gannt-chart/1

But unless development mode is turned on this script does not work and is just blank with no data.

I tried setting up a page rule with cache level on bypass on this url with no luck.

Please let me know if there is anything else I can try to make this work.

Thanks!

I see some console errors:

If you Purge Everything from the Cloudflare dashboard, does it work?

Do you have Minify turned on for JavaScript in the Speed → Optimization tab?

Minify is turned off and I have tried to purge everything with still no luck. Any other suggestions?

It sure sounds like a Dev Mode “un-feature” is the culprit. Here’s what’s disabled from Dev Mode that you might be able to manually toggle:
https://developers.cloudflare.com/cache/reference/development-mode
And I really don’t see anything that might be the issue, other than minification.

Turning off all minify actually fixed it. Thanks so much!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.