Same issues as before even after purchasing APO

Original thread:
https://community.cloudflare.com/t/why-i-am-getting-better-fcp-with-cache-bypassed-in-psi/
I installed this time the oficial Cloudflare plugin for Wordpress with paid Apo addon and so far I’m getting lower scores than usual (without Cloudflare plugins) on www.tomastestart.com
Usually FCP mobile is around 2.9 without Cloudflare plugins…
now is 1sec more

another screenshot analysis

If that’s the only test you run, I suggest you try other sources, such as Chrome’s own Lighthouse test. With mid-tier throttling, it shows good real-world performance:

I wouldn’t worry too much about that. Your TTFB is terrible with cache Bypass.
With APO, you can shorten TTFB significantly.
Test here:

I’m afraid I care about performance and SEO which means I intent to get high Pagespeed scores.
and oj since my website doesn’t have much traffic you need to run PS several times.

But Pagespeed is based on Lighthouse…

And just tried 3 tests, and having developer mode still outperformed in score and also I get more stable results, so If you ask me what I would choose right now is no Cloudflare sadly :man_shrugging:

I will leave bypass cache on, so you can further compare, and remember the first run doesn’t account for cache. in the first run of PS series I got 96 mobile score with APO enabled, but since it was the first visit it didn’t use the Cloudflare cache as I got “Reduce initial server response time” warning which in the subsequent test was gone.

Thanks I will do further tests :wink:

Update:

Any idea/update on why PS scores are worst after enabling APO? and also is there any planned fix?

Google PageSpeed Insights tests with pragma no cache, which will be respected by APO, thats why on some synthetic APOs cache gets bypassed. But I just found out something else. APO already thinks that your site is dynamic and it can not cache your homepage. That should be fixed and you should see some performance boost.

APO is active but on bypass, even if I disable the “Disable cache” option.

This ofc is against the advertisement: https://developers.cloudflare.com/automatic-platform-optimization/

Automatic Platform Optimization is the result of using the power of Cloudflare Workers to intelligently cache dynamic content. By caching dynamic content, Cloudflare can serve the entire website from our edge network to make a site’s time to first byte (TTFB) both fast and consistent.

But you first should watch out of you have your Cloudflare account not in developer mode and no PageRule that is set to bypass etc. Try to figure out why it is in dynamic and try to fix it, then things will be better.

If you really care about performance also try to focus on native optimization… that will do a lot on your website. Also please keep in mind APO in first place is to get down the TTFB, not for optimization in general. Your files itself are not getting optimized by APO nor the loadingorder. Your page requires 46 requests to be able to display that page while it easily could be less then 10. Don’t expect magic from APO in any other regard then TTFB.

1 Like

Thank you so much!!

Okey right now I have a rule on bypass cache, but I can of course disable it to figure out why is on dynamic… :wink: Ok disabled that rule and activated APO

I totally agree there’s a couple of things to further optimize on my to-do list like replacing fontawesome library (140kb load) for standalone svg icons but other than that I would appreciate further advice if possible there as well. I’m running Wordpress on my site but with a custom /hand made developed theme.

TTFB should improve then “Reduce initial server response time” Pagespeed" opportunity?
Also thank you I didn’t know how to call before “native optimizations” I wonder how are usually called
called “non native” optimizations?

Should I have the last rule enabled?

I personally call them native optimization, dunno if that is a standard or not, I guess not. But the others I call “On the fly optimization” Cloudflare offers a bunch of them. Also “Plugins” belongs to those if they don’t optimize the source, but rather optimize things when requested. So most compression is added on the fly, but ofc you can precompress stuff if you want. Depends on.

You can also call them Cloud-Optimization, or CDN optimization. They don’t optimize your site. They optimize how people see your site. So as long as you pay for these optimizations will be there, but since they are not implemented natively you depend now on this service.

You are welcome. I just tested again and your TTFB for me came down to about 40ms. From over 500ms. But don’t forget, the first call mostly always is uncached and cache must be warmed up. So, run benchmarks multiple times.


GPSI does not complain anymore about any slow responsetime. For GPSI the first call now was:

It did :slight_smile: APO’s job is done. Don’t expect anything else from APO then good TTFB.

Nope, Cache Everything is not required if APO is active.

Now it’s time to focus on all the other things Google complains about, like these:

Some are super easy, some will be a little harder to achive with Wordpress.

1 Like

I see thanks!! :slight_smile:

Yep I got 84 score mobile on first run and as you pointed the warning “Reduce initial server response time” was still there. For the following rounds the warning is gone but overall score decreases with 67, third 78, 4th 75, that’s what puzzles me why FCP is higher (worst)? is that a glitch or expected? If the second while improving TTFB comes at a a cost on other indicators?

Oh okey I am disabling it then…and checking the response headers this time I’m getting:.cf-cache-status:BYPASS

Ohh alright I tried in the past Rapidload Optimization plugin (unused css and critical css) but didn’t get good results :confused:

First contentfull pains gets mostly influenced by:

  1. Loadingorder
  2. preloads
  3. size of data untill first meaningfull thing is painted.

The overall score does not matter for optimization ATM, just focus on the red flags GPSI is providing you with and fix them. The problem is: your website and its many subresources are not constant at all. That means one time it will perform like this, sometimes like this.

With APO you have done the first step in the right direction and I see that you are confused about not beeing rewarded for this witha better GPSI score. Sometimes you need to make several steps to at the end beeing rewarded for. Do what GPSI complains about and after these things:

  1. font optimization (getting rid of unnecessary ones and adding correct font-display)
  2. eliminate renderblocking CSS and JS
  3. setting Browser Cache TTL to 1y (https://dash.cloudflare.com/?to=/:account/:zone/caching/configuration)
  4. preloading important files (preload CSS & most important picture)
  5. combining JS and CSS files

you should see some improvements.

1 Like

Alright! on it

    1. done.
    1. I think this one was ready all fonts are in woff2/woff fallback IIRC and font disdplay is set to swap
    1. I’m missing there preloading custom CSS and Bootstrap CSS. On it.
    1. I think Autoptimize is set for doing that, will check it.


Forgot to ask is getting BYPASS in resp. headers okey?

Remove the Icon-Fonts and replace them by inlineSVG, since these two fonts are producing a lot of trouble, exactly as the CSS they come from:

So after this is done, this should give a little boost. Report back, once you’re done.

Okey is finally done. Did 3 test each with dev mode and without, but bottom line I’m still getting better scores and less erratic with developer mode / not APO sadly, something else must be going on…

Tests without dev mode / APO enabled
test 1: overall score 86
First Contentful Paint 1.4 s
Time to Interactive 4.3 s
Speed Index 3.1 s
Total Blocking Time 240 ms
Largest Contentful Paint 3.2 s
Cumulative Layout Shift 0.005

test 2:overall score 66
First Contentful Paint 2.6 s
Time to Interactive 5.7 s
Speed Index 2.6 s
Total Blocking Time 490 ms
argest Contentful Paint 4.3 s
Cumulative Layout Shift 0.01

test 3: overall score 78
First Contentful Paint 2.4 s
Time to Interactive 5.6 s
Speed Index 2.8 s
Total Blocking Time 310 ms
Largest Contentful Paint 3.4 s
Cumulative Layout Shift 0.004

Tests with Dev mode enabled / APO disabled
Test 1: overall score 82
First Contentful Pain 1.4 s
Time to Interactive 4.4 s
Speed Index 4.1 s
Total Blocking Time 300 ms
Largest Contentful Paint 3.4 s
Cumulative Layout Shift 0.005

Test 2: overall score 85
First Contentful Paint 1.4 s
Time to Interactive 5.4 s
Speed Index 2.9 s
Total Blocking Time 210 ms
Largest Contentful Paint 3.3 s
Cumulative Layout Shift 0.005

Test 3: overall score 86
First Contentful Paint 1.2 s
Time to Interactive 5.4 s
Speed Index 3.5 s
Total Blocking Time 220 ms
Largest Contentful Paint 3.1 s
Cumulative Layout Shift 0.005

Edit : I just disabled dev mode…let me know if you need me to re-enable for further testing

Did another optimization: CSS files are not agregated into one file, so overall scores are better now but still getting better scores and metrics with Dev Mode.

I honestly can’t explain you why it performs worse with APO, then without in your tests. I can’t see any reason for this, since APO does not modify anything, it tries to make requests cached quicker and intelligently purge cache. AFAIK nothing is getting done to the content.

But alone this:

Would raise my concerns about what is wrong with my page. The speedindex is in 3 tests between 2.9s and 4.1s. It’s not about the absolut score, but about the fluctuation.

Thank you.

Would raise my concerns about what is wrong with my page. The speedindex is in 3 tests between 2.9s and 4.1s. It’s not about the absolut score, but about the fluctuation.

Good point, on the other hand the same happens with FCP with APO, but maybe yes is an “heritage” of sorts from the other metric. From the top of my head perhaps the webp images served in a unusual way may be contributing to this?

  • When the browser loads an image, our plugin checks if it supports the WebP format. If so, the image in WebP format is loaded.
  • The plugin does not make redirects in default mode, so the URL is always the same. Only the MIME type of the image changes to image/webp .
  • No redirects means no cache issues, faster and trouble-free operation of your website. If you want to know more about how it works, check out the plugin FAQ below.
  • It does not matter if the image display as an img HTML tag or you use background-image . It works always!
  • In case rewriting by rules from .htaccess file is blocked, a mode is available which loads images via PHP file. Then image URLs are changed, but the logic of operation is the same as in the case of the default mode.

I can of course try disabling that plugin and trying to see what happens, but other that I don’t know what else is the cause of the fluctuation.

Update:Okey tried that but forgot to post It made at the time no difference…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.