Safesearch not working!

I’m not sure what i’m doing wrong but this is driving me crazy. How is it something so simple requires hours to setup and still doesn’t work ? With DNSFilter or NextDNS, all you need to do is one simple click and safesearch works for all search engines, for all browsers !

Ensure that SafeSearch is enabled in your individual browser settings. Sometimes, browsers have their own SafeSearch settings that may need to be configured separately.