Safe search not enabled on

Google Safe search isn’t being forced on via Is this a known issue?

@neversphere Google safe search should be enabled via, but YouTube restricted mode is disabled. I tested this out on my end and it appears to be working. Are you seeing the same?

No, Google safe search was not enabled. The test adult content site was blocked (as were some real ones) but safe search was not enabled. I might have been hitting the ipv6 DNS server (I don’t know how windows picks the protocol it is using for DNS).

I ended up installing dnsmasq on my router and adding a cname for youtube, google, and bing.

Safe search for Google and Bing is enabled now. Thanks Cloudflare.


Safe search works for, but not for other domains.
In my case in it doesn’t work.
You can start a search for adult content and see the explicit results in the images tab of

1 Like