Running "" -- Just Started Using Cloudflare and Need Help!


I started the site “” to help with COVID19 information, and the site has just really gotten popular and overgrown the capability of managed WP at DreamHost.

I moved to Cloudflare this afternoon, and don’t’ have a lot of experience with this all… just trying to help this site thrive under all this traffic!

I’m getting messages like this:

Can anyone help me out?

1 Like

Right now the site isn’t using Cloudflare Proxy. Your DNS is probably set to :grey: for the website’s hostname.

It looks like you can cache the main page without many repercussions, as it doesn’t look like it’s dynamic content (comments, logins, etc).

Page Rule #1: Match:* and add a Setting for Forwarding URL to$1 (this will save hits to your server just to redirect to www)

Page Rule #2: Match: and add settings: Cache Level (Cache Everything) and Edge Cache TTL (2 Hours or more, depending on preference). This will force-cache the main page. If you update it, hit the Cloudflare dashboard and do a Purge by URL for just the main page.


I really appreciate you weighing in!

I… don’t know where to put those things. Like, I’m kind of proficient with this, but that looks a bit “high-intermediate” to “advanced.” :slight_smile:

I think the issue before was an SSL error that… SHOULD be fixed? But I’m still trying to help this poor little site anyway I can, getting slammed with +100k visits/day :eyes:


Sorry about the confusion. Right now your site isn’t proxied by Cloudflare, but SSL looks good. So in Cloudflare’s SSL/TLS, you should be using Full (Strict). “Too Many Redirects” is usually caused by a HTTP/HTTPS mismatch between Cloudflare and your site and it redirects back and forth between the HTTP and HTTPS. Full/Strict should prevent this.


Yep! Dreamhost helped me figure that out, and that’s how it is currently set.

Thanks, @sdayman!!

If there’s anything I can do to help my site out, please LMK! I’m all ears.


It’s still not proxied by Cloudflare. Your Cloudflare DNS entries for and www need to be set to :orange:

1 Like

Ok, cool.

Do you have a “dummies” version of that, so I know how to fix it?

1 Like

Go the DNS settings for your domain in the Cloudflare Dashboard. And then:


Hmm… they are all orange already! Please advise :slight_smile:

Screen Shot 2020-03-11 at 10.06.25 PM

Hi @flattenthecurve,

They do appear to be successfully proxied now. Are you still receiving reports of any issues with the site?

No but when I visit the site currently it takes a time to load.

Traffic appears to be way down as well… any advice?

How frequently is the home page updated? Could you cache it at Cloudflare for a day or more, or even a few hours? This would improve load time, but any changes may not show for a while, or you may have to purge manually when you make any changes.

Currently down… purging the cache right now will help? Our only if I make changes?

The site does eventually load, but sometimes it takes 5-10 seconds…

It does load for me, but very slowly. Caching at Cloudflare may help with that, but I suspect your server is just responding very slowly, maybe due to a large volume of traffic.

Yes… I just maxed out the hosting tier @ Wordpress managed WP hosting (DreamPress) and traffic improved some. But its on track to do 300k pageviews/day, so I understand that is slowing things down, even with highest-tier hosting and cloudflare.

I’m open to any and all ideas here if you have them! :slight_smile:

How frequently does the content on your site change?

If you follow this advice from @sdayman, the caching should help, as long as the site doesn’t change that frequently.

The site will be updated with one new page today, and maybe next week an update on the home page, but that’s it. Not a ton of content at the moment.

The only problem is… I don’t know how to implement… “page rules” – where do I go to input these?


Ah I just found it… Is it like this?

BTW, DiscoBot says I can’t make anymore replies and I have to wait 10 hours, so… can someone DM me @seanmarkey on Twitter to help? @domjh