Run 1 specific page on HTTP

Hey, so I run in to a problem today with running 1 single page on HTTP and the rest of the site on HTTPS. Which should be possible by setting a SSL page rule to Off if I am right. Sadly enough when I do this that one page gives the redirected you too many times. error, which is logical since when I watch at the network tab it shows me that it is looping true a redirect of http to https, it redirects the user infinity from https to http to https to http etc.

I tried running both full strict and flexible with the same result. Also tried to fully uninstall the cert on my server but also no success

Any way to fix this?

Thanks in advance!

Were you changing the global SSL setting or just through page rules?

If you were using page rules, can you show us how’s your page rule looks like?


I am using page rules to make the 1 single page on http, my global ssl mode is currently on flexible

Sounds like your running into a classic case of the redirect loop due to Flexible SSL mode:

When I am using Full strict ssl it also returns me the same error

Anyone?

Hi,

Remember you have 2 separate connections, what one do you want http only? Are you sure origin is not redirecting ?

Regards

So there was actually a cashing problem which made my original server did redirect to https. This is now solved. But now I run in to a new problem. I enabled Always use HTTPS to make cloudflare redirect to https on each page. But this returns me the to many redirect’s error again on the page without ssl. (Which is logical) but how do you fix it? Since I need every page to run on HTTPS except the page with SSL = Off.

Hi,

Instead of enabling Always Use HTTP on Domain level try to use Page rules, First define your url ( you do not have to specify protocol ) and disable SSL rule and then define your whole domain and enable Always use HTTPS

Regards,
Miroslaw Pabian

Already tried that. But page rules only work on 1 specific page. So setting a page rule for your domain will only enable Always use HTTPS for that single URL

Try something like this:

1 Like

aa, the always use HTTPS does work now when using * but even tho I set the SSL: Off above it, it is still getting in the same redirecting loop form http to https to http…

Try to not put protocol in front and you will be fine, also make sure you have no cached redirect in browser you testing from.

2 Likes

Thanks mate. That worked. Also thanks to everyone who helped!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.