Rules not working

Full of self-doubt getting my Rule to work. I had an old rule in place and it used to work fine (when I was proxing to you). I’d since changed to point the DNS to elsewhere, and when I moved it back to proxying through you, the Rule no longer works.

I have an almost identical Rule set up for the naked domain and it works fine. Have also deleted and recreated the rules and the dns entry.

@ → A record ( + proxying
blog → A record ( + proxying

  1.* → Forwarding Url ($1) ← not working
  2.* → Forwarding Url ($1)

Were you using Kinsta before? I believe they use Cloudflare, so they may now control all your settings, including Page Rules.

That’s actually the conclusion I was starting to reach so I’m already talking to them about it. Definitely a little disconcerting to discover that they had any control of my DNS without me knowing it and that there’s no indication of that anywhere. That does also explain how my site ended up hosed while I was on holiday when they said it wouldn’t. Hey-ho.

Will update in here once I confirm and then close this off.

Thanks for the amazingly fast response.

1 Like

I removed the domain on the Kinsta side and the rules started working as expected.

I’m trying to get to the bottom of it because I don’t want there to be a situation where there is an invisible integration that they still have control over.

So far I’ve had fairly unsatisfactory responses from the team at Kinsta regarding what their integration with CF looks like (they’re saying that they don’t control anything in my CF account). There is a verification step where we needed to add a Kinsta specific key to our domain for the “integration” initially, but I’m not sure who was verifying what in that case.

I don’t suppose you know anything else about the nature of the integration?

Technically, that’s correct. Using Kinsta essentially cedes control to their account. For now. I now Cloudflare is working on O2O (Orange to Orange), meaning if you :orange: a hostname that ultimately points to a proxied server, that you’ll have some settings control, such as Page Rules.

Do you know how I can confirm that I’m no longer ceding any control to their account?

If your Page Rule works, then control has returned to you.

You can also try a Firewall Rule to Block, like:
(http.request.uri.path eq "/foobar")

Then try

There’s no Page Rule for ‘www’, so this should go straight to Firewall Rule.

Great. Thanks for all your help.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.