Rules not matching wildcard

Hello,

I am trying to create a Cache Rule to bypass certain images using the asterisk wildcard.
The expression looks as follows:

(http.request.full_uri eq "https://*domain.example.com/*/live.jpg")

I still receive cf-cache-status: HIT

If I create an expression without wildcards, the bypass works.

(http.request.full_uri eq "https://subdomain.example.com/path1/live.jpg")

I observe the same behavior for Redirect Rules. So I assume, as if * is not working as a wildcard?
What am I doing wrong here?

The new Rules Engine does not use Wildcards.

Best to use a ‘Hostname’ CONTAINS domain.example.com AND ‘URI Path’ CONTAINS live.jpg

1 Like

Hi @sdayman,

thanks for the information!
I got it working with a combination of ANDs and ORs.

Didn’t know that wildcards are not supported. Do you maybe have an idea, if this might change in the future? Wildcards are working with the “old” page rules.

Regex is also offered as an option, but this seems to be only available for other plans.

Thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.