Rule Redirect Error

I entered a new domain in my Cloudflare account, I entered the parameters to point to my server and then I added a redirect rule but at the moment, after 24 hours, it is not working …
Reading the previously opened articles the problem could be caused by the cache or by not setting the DNS parameter to + ip + proxy (I have set everything) but it gives me an error on my server and does not forward.

Can you advise me to solve the problem. Thank you

curl https://www.emporiodelgusto.org -v
....
> GET / HTTP/2
> Host: www.emporiodelgusto.org
> user-agent: curl/7.77.0
> accept: */*
>
* Connection state changed (MAX_CONCURRENT_STREAMS == 256)!
< HTTP/2 301
< date: Tue, 15 Feb 2022 15:34:20 GMT
< location: https://m.facebook.com/GastronomiaEmporioDelGusto/

Seems like the page rule worked for me. Do keep in mind that the page rule you have configured only works when you exactly visit www.emporiodelgusto.org/.
If you want the redirect to work for all links on your www hostname, you have to change your page rule to be www.emporiodelgusto.org/* instead.

Good morning,
I did as he told me, look at the attached photo, but it’s not a good setting. I need the redirect to do it independently with or without www. and / , so that I, by typing only emporiodelgusto.org, make my redirect when I send it.
No one would Google www.emporiodelgusto.org/
with / * at the end.
How can we solve?
A thousand thanks!

If you want to redirect all requests as described then the page rule should match:

*emporiodelgusto.org/*

Users don’t type the * in their browser, it is a wildcard that means anything. And the / is always there, even if a user does not type it.

So in the rule if I write https://emporiodelgusto.org/* you tell me that it works???
Or as she wrote, I just have to enter exactly emporiodelgusto.org/ and it should work??