Rsync Synology to QNAP NAS with CloudFlare - No response

I’ve got Cloudflare successfully working on all my services that I want except Rsync and as a relatively noob at network stuff I’m at a lose.

What I’m trying to achieve is one way auto sync data when a remote client puts files in a certain folder it transfers to me, large expected files so cloud services not really an option. The Rsync origin is a Synology NAS to my QNAP NAS.

I’ve had Rsync working before prior to moving to a pfSense router and Cloudflare using QNAP’s myqnapcloud(dot)com DDS, but I wanted to move away from that for greater security and the fact bots target the domain to try and again access to NAS’, which obviously can hammer my connection and NAS resources.

I’ve created as subdomain in Zero Trust’s Public hostnames, such as transfers(dot)domain(dot)com, I’ve no idea which service type to enter (HTTP, SSH, etc), I’ve tried all of them, still can’t connect, added my NAS IP address and port.

I read something about grey cloud, and Rsyc won’t go though Cloudflare’s proxy, so under DNS and my subdomain transfers I’ve set it to DNS only turning off Proxy. Still no connection on the Synology to my QNAP…

I’ve entered my public IP into the Rsync settings on the Synology and I get a successful connection pretty much instantly, so I can rule out firewall rules, ports closed, NAS settings either end, etc, so it has to be either Cloudflare not passing on the traffic properly to my public IP, or the Synology doesn’t like transfers(dot)domain(dot)com but I don’t get any error to suggest that. I could roll with using my public IP but a) I don’t have a static IP, and b) I’d rather not have that exposed if the Synology NAS was compromised.

We successfully set up raunchy but not via a public domain. This is not possible.

We set up Cloudflared instances in some of our vlans and we are using Cloudflare Warp for client connections und for server to server connection we are using the new Cloudflare gateway Linux application. Then you are fully flexible in setting up your network

You can of course set up this gateway directly on your Synology via Docker container but for the moment you have to create your own alpine image with the packages the gateway needs