RSS Feeds Caching Problem on my website

I have been using cloudflare with two page rules till date which was working good.
1st Rule: libertatem.in/wp-admin [astrik mark at beginning and end]
Cache Level: Bypass

2nd Rule: libertatem.in/ [astrik mark at beginning and end]
Rocket Loader: On, Browser Cache TTL: 30 minutes, Always Online: On, Cache Level: Cache Everything, Edge Cache TTL: 2 hours

However, when I used mailchimp to send newsletter, new feeds never appeared on the mailchimp or any other email sender. But when I opened the feeds page. I could see all latest feed there. That meant RSS Feed code was having all latest publication as per and last modified but none of the email campaign senders were fetching the feed. I checked the feed validation from W3 Feed Validator and it was showing valid. Experimenting on it, I paused cloudflare on the website and the the feeds started working just fine. Hence, I decided to add an exception to bypass cache using a page rule.

On the website, the posts are posted every 30 minutes as it is a news website, but the newsletters never went for 2 days and newsletter was fetching posts from 7th June instead of 13th June. I cleared all CF Cache as well as W3 total cache. but clearing cache never worked but as soon as I paused cloudlfare. It worked.

I have multiple feeds based on different category. My Feeds are at following links:
https://libertatem.in/category/articles/feed
https://libertatem.in/category/government/feed
https://libertatem.in/category/economy/feed
https://libertatem.in/category/law/feed
https://libertatem.in/category/law/high-court/feed
https://libertatem.in/category/law/supreme-court/feed
https://libertatem.in/category/law/tribunals/feed
https://libertatem.in/category/parley-with-the-pirates/feed
https://libertatem.in/category/events-opportunities/feed
https://libertatem.in/category/jobs-internships/feed

All I want to ask, can all these feeds be excluded if I add this page rule:
libertatem.in//feed/ [astrik mark at beginning and between libertatem.in/ /feed]
Cache Level: Bypass

I have been using cloudflare with two page rules till date which was working good.
1st Rule : libertatem.in/wp-admin [astrik mark at beginning and end]
Cache Level: Bypass

2nd Rule : libertatem.in/ [astrik mark at beginning and end]
Rocket Loader: On, Browser Cache TTL: 30 minutes, Always Online: On, Cache Level: Cache Everything [updated, removed Edge Cache TTL]

However, when I used mailchimp to send newsletter, new feeds never appeared on the mailchimp or any other email sender or feedreader. But when I opened the feeds page. I could see all latest feed there. That meant RSS Feed code was having all latest publication as per and last modified but none of the email campaign senders were fetching the feed. I checked the feed validation from W3 Feed Validator and it was showing valid. Experimenting on it, I paused cloudflare on the website and the the feeds started working just fine. Hence, I decided to add an exception to bypass cache using a page rule.

On the website, the posts are posted every 30 minutes to 1 hour as it is a news website, but the newsletters never went for 2 days and newsletter was fetching posts from 9th June instead of 16th June. I cleared all CF Cache as well as W3 total cache. but clearing cache never worked but as soon as I paused cloudlfare. It worked.

I have multiple feeds based on different category. My Feeds are at following links:
https://libertatem.in/category/articles/feed
https://libertatem.in/category/government/feed
https://libertatem.in/category/economy/feed
https://libertatem.in/category/law/feed
https://libertatem.in/category/law/high-court/feed
https://libertatem.in/category/law/supreme-court/feed
https://libertatem.in/category/law/tribunals/feed
https://libertatem.in/category/parley-with-the-pirates/feed
https://libertatem.in/category/events-opportunities/feed
https://libertatem.in/category/jobs-internships/feed

Please help as soon as possible.

Hi,

You may want to edit your post and mark your URLs as code (see the </> icon on the top of editing window), so that the asterisks you mark show up correctly.

Yes, a rule for example.com/*feed* should prevent these pages from being cached.

You may also want to change the URL pattern on your first rule from:

example.com/wp-admin* to
example.com/wp-*

and remove the setting to bypass cache. Please find a fuller explanation here.

By making this change, you will prevent the caching of /wp-json.php and other WP related dynamic content, which may also be at play here.

This topic was automatically closed after 30 days. New replies are no longer allowed.