RSS Feed Not Validating

The RSS feed for my site isn’t validating.

I was able to confirm that disabling Cloudflare proxying fixed the problem. It seems that there is some interaction specifically with Cloudflare that is causing the compression on my sites RSS feed that is causing it to fail validation.

If that so, you can disable the Cloudflare cache for your /feed/ URL using Page Rules.

Do you already use some of the Page Rules, if any?

For*feed* should prevent these pages from being cached.

Or disable the Brotli compression for the needed URL:

Moreover, I have not yet seen that kind of an issue using RSS feed from WordPress and having Cloudflare with “Cache Everything”.

Have you tried validating it via Direct Input?:

Does your Web server return as content-type MIME application/xml, or text/html or gzip - regarding the Cloudflare?

Or is there any optimization at the origin/host of the content?

I got returned content-type: application/rss+xml; charset=UTF-8

Thanks! I just disabled the Cloudflare apps, security, and performance for feed on my domain.

This is the error I get.
Not a gzipped file (Server response declares Content-Encoding: gzip; misconfigured server?) [help]

I sure wish those feed validators would actually show the response they’re getting. I finally got this out of one of the validators:

Check your Firewall Event Log to see if you’re blocking these tests for some reason.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.