RSS Feed - Internal Server Error 500

Hi,

my RSS feed is generated as “www.stratecta.exchange/feed/” however when validating it with https://validator.w3.org/feed/ it gives an Internal Server Error 500.

The feed can also not be loaded in Feedly.

I created a page rule not to cache and tried some other solutions mentioned in forums, however nothing helped.

thanks br
Georg

Same issue here

sitemeer.com/#https://www.stratecta.exchange/feed/

It seems to be Worker related. Check out the Worker you have mapped onto that path and debug its code, respectively check why it throws an error. In particular check if your code handles or requires the Accept header.

I am getting an Internal Server Error 500 on my RSS Blog Feed - https://thewarehouse.blog/feed

Siteground says everything looks good on their end. My podcast feed runs through Powerpress on the same site and it also is returning a 500 error. The Blubrry support team speculated it was a Cloudflare issue. Here is what I’ve tried so far…

  • Disabled all plugins
  • Set a rule exception for security/caching
  • Changed WP theme back to Twenty Twenty

The strange part is that I have Mailchimp set up to send an RSS email out with every new blog post. It fails to send an auto email but when I send a test email through their server, it works. Any help is greatly appreciated.

stratecta is now showing a 200 (success) on Sitemeer.

thewarehouse is not using Cloudflare.

I am configured through Siteground.

I saw that, but when I tested the feed, it was coming straight from Siteground. Now it’s proxied by Cloudflare and is showing a 200 (Success) as well.

My first try had a long delay, but it did present the feed, beginning with Isaiah 51. Subsequent visits were much faster.

Yep, the OP appears to have fixed the issue.

1 Like

Thank you for checking into this. Any idea on why this is still returning a 500 error on https://validator.w3.org?

Hi,

on my site “stratecta.exchange” the problem was due to the Workers. I disabled the Workers on “stratecta.exchange/feed” and then it worked.

br
Georg

1 Like

Thanks for reporting back. In my case, that did not work. Still getting the 500 error when trying to validate my feed.

HI,

please try to disable the workers fully at first. Then check the feed with the validator after the cache has been purged. If it works then set the workers up again - and first the exeption worker for “…/feed/” and then for your site.
This was how it worked for my site.
br
Georg

Thank you! It is definitely a workers related issue. When I disable for the entire site, validation works. However, when I set it back up as you advised, I am back to getting the 500 error. For my site, I am using “…/feed/” for the exception and “…/*” for my site. Is this how yours is set up? I’m wondering if it is prioritizing the site worker above the exception?

Do you have your own Worker configured?

I did see in another thread that SiteGround has recently added their own Workers, so you may have to contact them.

When I hit manage workers it is asking me to set up a subdomain so I’m assuming I do not have it set up. This is all new to me.

EDIT: Yes, you are correct. The worker set up is sg_worker from Siteground. I will contact them and update.

1 Like

Just to update, this was verified as a Siteground Optimizer issue and they assured me a permanent solution is in the works. In the meantime, creating an exception for both “…/feed” and “…/feed/” will validate the RSS feed.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.