RSS caching problem


I have a podcast feed that is not updating properly.

The symptoms are this:

  1. If I load the URL of the feed directly into the browser and view source, it’s correctly updated


  1. Any external access of the page (eg via CastFeedValidator or the w3 validator) seems to only ever get an old (presumably cached) version of the feed. This is a problem, because iTunes seems to also only ever get this same old version which means it refuses to update. I have no idea how to purge this cached version. I’ve purged everything in Cloudflare, I’ve set the feed url to bypass caching. But things keep getting stuck on this old version.

It’s very possible there’s something obvious I’m missing, and I’m open to any suggestions at this point. Because I’m utterly flummoxed. I don’t understand how the same URL can output a different feed XML depending on whether it’s examined via the browser or via some other interface.

Any help or suggestions would be appreciated. I’ve been trying for days to convince these places to read the updated version of the feed that I can clearly see in my browser. It’s driving me mental.



Hi Dan,

Your chances of getting meaningful help here in the Community Forum will increase in case you don’t mind sharing:

The URL where the issue can be found, that is, the RSS feed URL; and

A screenshot of your Page Rules, if any.

Hi, Thanks for responding.

The URL is

If I plug this URL into Chrome it has 13 episodes and was last updated 9 May. This is correct.

But iTunes doesn’t recognise the most recent episode. And nor does or which return only 8 episodes with a lastBuildDate of 24 Apr. So my assumption is that iTunes is reading the feed the same way these validators are, ie picking up some cached version from somewhere, somehow.

I didn’t have any rules originally. Butas one of my many attempts to fix this, I added the following rule yesterday.

Any insight would be great. Thanks.

I’m not sure if you saw my response with the URL and screenshot. It’s apparently been flagged as spam.

But, update: I’ve now determined that the only way to see the updated version of the feed is if I’m signed into Wordpress. Otherwise my browser also shows the non-updated version. I need to do some googling and thinking to see if I can work out what that means. It may not be a caching problem at all.

1 Like

Another update. Working in incognito mode (or equivalent) on four separate browsers, this is what I’ve now got happening:

  1. The first time I enter the URL, I get the old content (8 records)
  2. The second time I enter it, either by refreshing or by opening a new tab and entering it again, I get refreshed content.

I’m not even sure how to type the concept into google to unravel the problem, but it feels like I’m only one step away now from solving this.

1 Like

I looked at the url in a browser. I see 8 entries. Episodes 5 through 12.
Then I hit reload and see all 13.
This IS strange!

Being that I’ve never visited before, it may be some funky caching mechanism by SSP.

I’ve made some more progress. On the first time you load, it sets a cookie. Then when you reload that cookie seems to allow the updated page to load. I don’t really understand why. For now, I’m turning Cloudflare off until I have more time to work this out.

1 Like


Regarding your page rule, it should not have any effect on this and you can disable it. Cloudflare by default will not cache non-static content, unless you specifically tell it to with a “cache everything” page rule.

As for the feed itself, Developer Tools point to two issues, not sure if related to your problem:

Mixed content, as the JPG image is being served by http, not https; and
A stylesheet (.xsl file) being sent with MIME type application/xml.

Since you took the feed off Cloudflare, I of course am seeing the new feed (13 episodes) as mentioned by your earlier replies.

I hope you find a solution soon.

Thanks for your help. I’ll come back and have a look at some point.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.