Routing to incorrect continent

Hi there,

Thanks for your time.

I moved my DNS to Cloudflare recently, everything seems perfect except this one.

My server is in Germany and I am trying to test the routing inside Germany.
However, a trivial traceroute indicates that accessing the domain resulting in a route to America.

As far as I know, Cloudflare has edge servers in Frankfurt. How is this happening? Does that mean access cross-continent is even faster than access server inside a country?

I also enabled Argo, but the situation seems not improved.
I also read this thread Routing wrong country, it suggests access yourdomain.com/cdn-cgi/trace. Indeed my result shows colo=FRA, but it doesn’t explain why traceroute goes to another continent.

Moreover, a quick skim on this article https://blog.cloudflare.com/bandwidth-costs-around-the-world/, Germany seems not on the list?

Did I miss anything? What did I do wrong? How to improve and resolve the issue?

Here is the traceroute result:

traceroute to (104.24.121.175), 64 hops max, 52 byte packets
 1  192.168.0.1 (192.168.0.1)  3.632 ms  3.457 ms  3.196 ms
 2  10.220.160.1 (10.220.160.1)  11.810 ms  10.444 ms  9.847 ms
 3  109.125.81.68.dynamic.cablesurf.de (109.125.81.68)  10.641 ms  14.802 ms  15.953 ms
 4  109.104.59.136 (109.104.59.136)  12.650 ms  11.768 ms  11.812 ms
 5  bymuc-mc01.hlkomm.net (109.104.61.46)  12.168 ms  11.571 ms  15.761 ms
 6  ae0-405.muc10.core-backbone.com (80.255.14.205)  12.317 ms  11.484 ms  12.397 ms
 7  ae2-2054.prg10.core-backbone.com (81.95.15.134)  25.914 ms  23.672 ms  22.167 ms
 8  * * *
 9  104.24.121.175 (104.24.121.175)  33.383 ms  23.419 ms  24.137 m

May be IPv4 is served from USA and IPv6 from FRA

Thank you so much for your quick response. It sounds reasonable. Is there a way to make sure at least all requests in Germany will stay in Europe?

Where does it indicate that? As far as I interpret your traceroute your requests go to the Czech datacentre. That would be slightly weird if the status page actually shows the German PoP, however there is no indication any of that connection even left mainland Europe, let alone via the US.

Are you misled by the IP address? #Tutorials has a dedicated article on that.

1 Like

Do you mean the last route (9) is a virtual routing and it has no cost for that?

Beyond that, indeed you pointed another issue, why the routing wen to Czech? I tested several times, it mostly went outside Germany, such as Finland, Czech, etc.

You might want to check out support.cloudflare.com to understand how Cloudflare works.

If your status page showed the German PoP you should hit the right PoP.

I understand the part that Cloudflare tries to hide my source IP. But could you please point out which page specifically explains how it works with no cost in routing to a Cloudflare IP?

Let’s get back to the original issue. It sounds like you have a routing question, even though you see your site is using the Frankfurt datacenter.

You’ve enabled Argo, but aren’t seeing improvement. Where is your server? Have you checked Analytics -> Performance for Argo stats?

Attempting a traceroute will not show you the route Cloudflare uses to reach your server.

Thank you for your response. The performance test shows there are significant improvements for US regions, that’s for sure. But for European regions seems not too much (or maybe I shouldn’t expect that much)?

The performance from Asia is still missing, it is also particularly interested in the improvements from Japan, Singapore, China, etc. My trivial test shows that Japan and Singapore are very good and less 10 ms, but China seems not that significant and not even routing to nearby such as Japan?

Attempting a traceroute will not show you the route Cloudflare uses to reach your server.

If so, how could I know an actual route uses to reach the server?

I am not quite sure about your question.

I already addressed that in my first response and referred to the tutorial.

So, again you are routed via the German PoP, are you not?

Actually even the Czech address I referred to seems to be within Germany, so your whole request goes to a German datacentre and then onwards to your server. Routing seems to be fine.

I don’t expect you’ll see much improvement in China. Not without stepping up to Enterprise with Chinese datacenters. And if I recall, you can’t have both sets of datacenters if you go this route, but I could be wrong.

China is a whole different subject, but the original concern was why a European request is routed to the US, which it isn’t.

1 Like

It looks like these two are relevant. The traceroute shows IP (104.24.121.175) is geolocated at Chicago.
I do not fully understand how Cloudflare works but I think I know the basic concept. So the question is, if I am confused by the IP, should somehow be an IP in Europe instead of the USA?

What’s the actual route when visiting the site?
How Cloudflare solves the traceroute to the USA but actually not?

That is precisely what I referred to earlier. Please do read my responses, as well as the articles and links I referred to.

Sure, let’s leave that as off-topic.

You said there is an article. But I didn’t see which one. Could you maybe point it specifically?

Ehm, that’s right at the link I posted. It’s even called “Why does my site return a US IP address”.

1 Like