Roundcube 524 A timeout occurred

I can access webmail properly, but when I click on Roundcube and start opening, I just get error 524! Does anyone have any experience?

Where exactly do you click? :thinking:
On the logo, or login button or somewhere else?

Does any error appear in the Console of the Developer Tools (F12) at your Web browser? :thinking:

May I ask what troubleshooting steps have you already tried regarding the 524 error you’re getting for your Website from the article below? :thinking:

Before moving to Cloudflare, was your Website working over HTTPS connection?
You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

What port are you using to access your Webmail?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Hello, when I pause Cloudflare everything works normally, however when I turn on Cloudflare I cannot access webmail as an end user but I can access it with the root password via the WHM interface > user accounts > webmail > click on Roundcube . I USE FULL SSL. The end user goes to webmail and logs in normally, but when he clicks on Roundcube (image or button) after a few minutes he gets a 524 error from Cloudflare

That would be port 2096 (https) or 2095 (http).

These are the ports used by WHM/cPanel for its webmail applications (RoundCube, SquirrelMail or Horde).

2096 port

I’m having the same issue.

Can access cpanel webmail through port: ==2083==

Get Error 524 through port: ==2096==

Temporarily disabling the proxy settings on Cloudflare will fix the issue (no errors through port: ==2096==)

Firewall at the origin does not rate limit Cloudflare’s connecting IPs.

Hosting provider confirmed no server issues or other related issues listed on the tutorial linked above.

Enabling proxy will bring the problem back.

Any ideas how I can fix this so I can enable proxy through Cloudflare?

@ jure did you find a fix?

there is simply no solution.

Is there any solution to this issue? I am having the exact problem myself and trying to troubleshoot it.

Same problem here, did anyone find a solution?