Root Domain Returns DNS Error

Hi,
I have recently started using cloudflare and I have a very annoying problem. So in the DNS section I have to records, one is the root domain and the other is www and they both point at the same IP but the root domain doesn’t work while the www one does. I have tried adding random records proxied and un proxied and they all worked axcept for the root domain.

I have found a few community posts of people with a similar problem but none of the solutions worked for me. I don’t know if it matters but i bought my domain name on domain.com.

I checked the root domain with https://mxtoolbox.com/ and it found my IP (proxy off) and the cloudflare IP (proxy on) but I still can connect to it nor can I ping it.

Here are my DNS records and the rule I tried:

It’s working for me. It resolves and then forwards me to the dashboard.

What? How? For me only www.krmafia.com works but krmafia.com just doesnt load and I’ve tried it on multiple devices.

1 Like

It resolves everywhere I’ve checked. Maybe you should change your DNS settings to something like 1.1.1.1

https://1.1.1.1/dns/

2 Likes

It worked!
Thank you soo much for your time!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.