Rocket Loader Update Is Active In WP-Admin

rocketloader

#1

Previously the older version of Rocket Loader automatically excluded the WordPress Admin Panel from being optimized.

However, since it appears the Rocket Loader has been updated (with some interesting changes) its enabled for the WordPress admin panel (when set to automatic mode) was this by design or just a mistake I have not noticed any issues so far was just curious.


#2

I’d like to read more about those updates. Where did you see mention of it (I’ve looked here and the blog, but I guess I missed it)?

The update has apparently been responsible for severe performance problems this week with WordFence’s Live Traffic feature, so it’s definitely had some effect!
https://wordpress.org/support/topic/apparent-attacks-and-why-wordfence-is-mention-in-the-logs/#post-10270202


#3

There have been some changes to RocketLoader which have been rolled out to a subset of zones. Additional changes/ tweaks may be forthcoming. And there is apparently a change in behavior in terms of not excluding wp-admin by default.

I’ve asked the team to look into possible WordFence issues.

Should term, one could use our recommended page rules for WordPress, one of which includes disabling performance for the WP-Admin portion of the site, which would disable Rocket Loader.


#4

I believe a blog post will be forthcoming. I don’t know the full details on the changes, but Rocket Loader has been getting some serious love from the development team.


#5

Hi,

I received a scary notice from SiteGround this morning about excessive CPU usage. SiteGround’s staff indicated the problem appeared to stem from Wordfence. Searching the Wordfence support forum, I found others with a similar problem.

I posted over on the WordFence wordpress forum Apparent attacks where it was suggested to switch off RocketLoader.

About 35 minutes ago I switched off RocketLoader and flushed the Cloudflare cache. According to my SiteGround stats, I have seen a dramatic decline in last 2hrs CPU time usage (20,000+ -> 3,000+) and last 2 hrs account executions (25,000+ -> 4,500+).

I hope this information is useful to someone. I hope also that SiteGround won’t penalize me!

Best, Ian


#6

Update: Having shut down RocketLoader about 2 hours ago, I am now down to 100 - 200 CPU seconds of usage the last 2 hours, and account executions are now in a similar range.

What is the prognosis here? Was there an actual problem with RocketLoader, or was it to do with how Wordfence interpreted RocketLoader’s activities? Will there be some notification that the issue is resolved and RocketLoader can be safely brought back on line?

Thanks, Ian


#7

Just want to report that I’m experiencing the same issues and it feels amazing to finally get to the bottom of it. I was tearing my hair out because I didnt understand what was going on.

Cloudflare, please look into this!


#8

@cscharff is there anything to report on this issue? Any resolution - I understand the Cloudflare and Wordfence teams have been in communication on this.


#9

I’d like to chime in with a report of the same issue for my site, i.e. CPU cycles wasted like there was no tomorrow and jQuery missing issues in certain panels of Wordfence admin. As I do not wish to disable WordFence, I have turned off RocketLoader for the time being, until the issue may be resolved.


#10

@rayner.ian / @markus.wollny_kirche thanks for reporting this. We’re looking into what the issue is with Rocket Loader and Word Fence. In the interim - you can either disable the Live Traffic feature in Word Fence or disable Rocket Loader. Either should ensure that specific issue goes away.

To answer the original question @scotth0407 the new Rocket Loader code is no longer disabled in wp-admin - this is an oversight but as the new code is much more compatible we don’t anticipate any issues (Word Fence is an issue outside of wp-admin) - if you are seeing any problems though, do let us know.


#11

@simon thanks for the update - and apologies, I didn’t realize we (the cpu cycle Wordfence / Rocket Loader people) had so egregiously threadjacked this conversation.
Ian


#12

@rayner.ian that’s absolutely fine! Just want you to know we’re working on it - we’ve actually found the issue that causes the problem with Word Fence & Rocket Loader and we’ll be rolling out a fix this week. I’ll update you guys when it is done.


#13

@rayner.ian @markus.wollny_kirche @bjf2000 this issue that was exhibited Word Fence’s live traffic is now fixed in the latest version of Rocket Loader - feel free to re-enable and let us know if you have any issues. Thanks again for the reports.

@arkonlabs - it wasn’t clear whether you were seeing an issue with Word Fence or something else - can you confirm?


#14

It was the issue with Wordfence, thanks for fixing it! I’ll re-enable it now.


#15

The update is terrible. Half of the scripts stopped on the site loaded. The other part stopped loading through Rocket Loader. I had to turn it off.


#16

@allod2008 can you drop a line to support with a URL where we can check this? Or put a URL here if you’re happy to - would love to take a look. You can leave Rocket Loader disabled and we can check internally.


#17

https://narutoplanet.ru/anime-catalog/1101-tokyo-ghoul


#18

Thanks @allod2008 - we’ll take a look at this but for anyone following along this is unrelated to Wordpress / Word Fence.


#19

The rocket loader update today broke my website completely. I had to totally disable rocket loader and now everything works fine. Instead of just loading the compressed script once at the top like it used to, it was loading the same script over and over again everytime there was a js file included. Rocket loader works great until it breaks your site suddenly without notice. Whatever update was done in the last 24 hours or so, please reverse it.


#20

In new rocket loader, I can not even use the manual mode. When I turn on manual mode, rocket loader use only automatic mode.