Rocket Loader stop working Visual Composer FrontEnd Editor

When I turn on Rocket Loader, WordPress Visual Composer FrontEnd Editor is stopped working. Does anyone have a solution for it? :cry:

**My page rules settings:**
Cache Level: Bypass*
Always Use HTTPS

Cache Level: Bypass

I just now had this issue. Elementor doesn’t like Rocket Loader. Their suggestion was to add a Page Rule to disable Rocket Loader for Elementor…matching URLs that have “elementor” in them.

I was in a hurry, so I just turned Rocket Loader off while I edited the page.

You don’t need the page rules to by-pass /wp-admin or preview pages, as they are not cached by default.

Also, you can set Always Use HTTPS on the SSL/TLS app.

So that would liberate your 3 page rules and you could use one to avoid using Rocket Loader.

However, since Visual Composer is always accessed from within /wp-admin, you could keep that first page rule and try adding the setting Rocket Loader to turn it off.

I believe Elementor runs within a frame in wp-admin, which would require a rule to match Elementor outside of wp-admin. Here are their instructions on the topic:

Ah, OK, I was just thinking Visual Composer. BTW, it would seem the 2 rules on the Elementor page could be just the first? :slight_smile: Have you tried?

No. Next time around I’ll give it a try.

1 Like

If you check the help section of Crypto, following instruction will appear:

Reply to all requests for URLs that use “HTTP” with a 301 redirect to the equivalent “https” URL. If you only want to redirect for a subset of requests, consider creating an “Always use HTTPS” page rule.

That’s the reason I have created always use HTTPS page rule. Am I wrong?

Kindly guide me.

I’m still confused is this useful for me or not?
Cache Level: Bypass

Am I need one more page rule? Such as,
Rocket Loader: OFF

At this time, I don’t have any plan to buy page rules! :disappointed_relieved:

Please guide me.
Thank you!

You should see Page Rules as a way to create exceptions to the settings you apply to your website. Say for instance you domain is

Crypto > Always Use HTTPS
All pages from,,, etc will be redirected to HTTPS for visitors requesting http.

Now let’s say you need for some reason to have NOT using https. Then you should turn Always Use HTTPS off on the dashboard, and create rules to match the other parts of your website for which you want HTTPS on. For example. > some settings Always use HTTPS

So that for the API section you’d not have Always Use HTTPS, for everything else, you would.

You should ask yourself this: do I want all pages from my website on HTTPS? If the answer is yes, then you should set this at the dashboard. If the answer is no, then you have to create the appropriate page rules.


You can keep this page rule, and edit it to add the setting: Rocket Loader: Off


Thank you so much for in-depth information regarding Cloudflare’s HTTPS or HTTP settings. I will follow your guideline.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.