Rocket loader javascript error

Looking at the Chrome console i have a Rocket Loader error…I’m not sure how to fix this.
I am using Wordpress with W3 Total Cache as well as Autoptomize plugin do defer Javascript.


Does this mean Rocket loader is not loading at all? not sure how to fix this.

Rocket loader is probably loading, but it might be messing up the execution order of your javascript files. With rocket loader, you have the option to exclude some scripts, but unless you know exactly what is going on in your website’s Javascript ecosystem, it’s not worth the hassle.

If I was you, I would simply disable Rocket loader. If your website is on SSL (https), all your Javascripts will be served from Cloudflare CDN through HTTP/2 (multiplexing) anyway, and I don’t think rocket loader will add any huge advantages to that.

Most importantly, does your website work wit rocket loader disabled?

Thanks for the input, i disabled Rocket Loader and still have the following error…


I’m not sure if this has anything to do with the other but I guess i need to find out where this error originates?

Looks to me like something related to minification of JS resources from your Wordpress cache plugin. Likely something related to the either minification order or load order.

Since your website is now served from SSL with HTTP/2, you might consider entirely disabling combing and minification from your cache plugin. The point of minification in the first place, is for the browser to avoid having to queue and make multiple connections to load several resources. With http/2, your resources are already loaded optimally through the same connection with multiplexing.

Thanks for the tip, I’ll make some changes in the caching plugin and see where that goes. Ill post with updates.

Turns out the error was caused by the JS Minification using a Non Blocking “defer” method and was easily fixed by changing to another method other than “defer”.

Thanks for your help on this.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.