Rocket Loader & FreshRSS Conflicts

TL;DR:

You can either switch off those Cloudflare options, or reduce the the security by removing CSP rules at your Web server level.

  • The first one is probably not an option since Rocket Loader helps to speed thing up?
    So, that leaves me with “removing CSP rules”? And I found this on Cloudfare:-

CSP compatibility with Cloudflare Rocket Loader:
**

script-src ‘self’ ajax.cloudflare.com;
**
? Where do I put/change this line of code?

PS: It will be nice if I can just switch off FreshRSS which is hosted on a subdomain like xxx.abc.comIs there a way to switch off Rocket Loader for subdomain?

You can create a Page Rule to match sub.example.com/* to set Rocket Loader to Off.

You probably don’t have CSP configured on your site, because if you did, you would have been the one who did it. Most people don’t do it because it frequently breaks things. So there’s nothing for you to do regarding CSP.

If you want to do more, you can open a ticket and let them know the situation, including the BUG link you posted.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Thanks.

Created Page Rule to match sub.example.com/* to set Rocket Loader to Off. But unfortunately, while this did stop the login page problem, I just found extensions installed to render certain functions all stop working for as long as it’s running behind Cloudfare.

The only way to fix the situation is basically to stop Cloudfare altogther.

Is there a way to stop Cloudfare on a subdomain?
What option in the Page Rule may I use to stop Cloudfare altogether?
SSL is probably not it becos the script need SSL?

You can try adding a bunch of OFF settings in that Page Rule, or just set that hostname to :grey: DNS Only by clicking on the :orange:.

Okay, what do I choose to switch off for "a bunch of OFF settings in that Page Rule? I don’t see any that suggest Cloudfare will be off?

set that hostname to :grey: DNS Only by clicking on the :orange:.
Now, I’d like to try this one, but I have no clue where do I begin… Like where can I change the settings for this?

Okay, I turned off the DNS’s “Proxy status” for the subdomain… Lets see what happens…?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.