Rocket loader does not work

I enabled “Rocket Loader” on my website but does not work.
It doesn’t add the “rocket-loader.min.js” at the page.

I know that DNS’s are well configured because I created a “Worker” test and it worked well and already displays access information on the dashboard.

Does anyone have any ideas?

May I ask where have you checked for that resource to be loaded?
How about checking into the Network tab at Developer Console (F12) of your Web browser if the request exists, or even at source code of the Website and looking for JavaScript tags?

Here is a great answer to check too:

As far as I know, cloudflare added a tag with src “rocket-loader.min.js” at the end body tag and adds some attributes to the existing tags to make an asynchronous load of them.

But in my case he didn’t add this script or make any changes to the script tags.

It didn’t change anything.

This is the page: https://www.4prime.com.br

The “Rocket Loader” is enabled.

May I ask have you tried to do below:

  1. Turn Rocket Loader “off”.
  2. Therefore, clear the cache (Purge) at Cloudfalre.
  3. And therafter, tried to enable it again “on”
  4. Clear your Web browser cache
  5. Re-check and make sure the www.4prime.com.br and 4prime.com.br DNS hostnames are :orange: proxied too

Does anything change after this?

For the resources being loaded I see the HTTP headers and one like x-cache: HIT.
Meaning you also have some cache at origin host.
Could you try to purge the cache from your application/CMS/store too?

Otherwise, if you are seeing some type of issue I would suggest opening a support ticket with CloudFlare directly so our support team can review your account settings.

I’ve already tried all these alternatives:

  • Disable Rocket Loader
  • Clear Cloudflare cache
  • Rehabilitate Rocket Loader
  • Clear browser cache

DNS is pointing correctly. To test it, I even created a Worker transforming the HTML and it worked correctly.

Actually this site is a third party ecommerce platform. It appears that the origin service has cache, but it is updated every 15 min. It’s been 2 days since I can’t enable Rocket Loader.

Also, I verified that when you put an item in the cart, the origin service cache is no longer used.

I did the same process on another site I have and Rocket Loader worked perfectly. Only on this site does not work.

I tried email support, but unfortunately they don’t support free accounts.

I did an interesting test here.

With “Rocket Loader”, cloudflare does not apply “rocket-loader.min.js” on my website.

So to find out if it was something with the site, I created a Worker that fetch another page. In this case, it works perfectly.

So possibly it’s something on the page (headers or html) that makes cloudflare not apply the Rocket Loader.

Is your origin setting Cache-Control: no-transform on responses? If so, Cloudflare will respect that instruction and will not modify your HTML which will stop Rocket Loader from being included.

You can test via:

curl -svo /dev/null https://www.4prime.com.br --connect-to ::1.2.3.4

Just replace 1.2.3.4 with your origin IP and look for the < Cache-Control response header line.

1 Like

It actually looks like “Cache-Control: no-transform” in the header.

As it is a third-party application, there is no way to change this header. Even so, I would really like to test this feature.

Is there any way to ignore this parameter?